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SyMBOL DESIGN TUTORIAL

Using this Tutorial

This tutorial is designed for intermediate level gINT users, and is intended for self-study. It covers the
use of the SYMBOL DESIGN application group, which provides a variety of applications for creating and
maintaining symbols of various types for use elsewhere in gINT, especially the “composite symbols”
that are used for lithology, sampler and well graphics, and the “tile” symbols from which they are
built. The tutorial employs some explanations, but mostly has you perform step-by-step instructions in
gINT.

You should have at least a little prior experience with working in the REPORT DESIGN tab prior to
working through the present tutorial. If you do not have this experience, either the Log Report Design
tutorial or corresponding gINT University course (gINT 004) is highly recommended.

Setting Up Sample Files

Before starting the tutorial, you need the following:

e gINT Version 8 installed on your computer

e Sample files installed in the appropriate subfolders of the \gINT\ installation folder (usually
C:\Program Files\gINT\)

To obtain and install the sample files, do the following:

1. Go to www.gintsoftware.com/support doc.html.

2. Click on the link ‘Standard Data Files for All gINT Tutorials’.

3. Extract the following files to the indicated locations:

File Destination
training.glb \gint\libraries\
training.gpj \gint\projects\

%~ Note: If these files are already present in the indicated locations because of working on another
tutorial, you do not need to replace them.

1
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SYMBOL DESIGN Overview

The SYMBOL DESIGN tab enables you to create and modify fill patterns for material, sampler and well
columns, non-repeating graphics for indicating water levels and curve points, and various other
symbols, lines and colors.

With the exception of bitmap symbols, which are primarily for bitmap (JPG or BMP) logos that you
import into reports, the symbols you use and maintain in gINT are line graphics. These are also called
vector graphics, and consist of line and curve objects. Line graphics are maintained using the glDraw
interface, which consists of the same drawing tools and other interface elements as are found in the
REPORT DESIGN and DRAWINGS tabs. If you employ closed polylines in your symbols, you can fill them
with a solid fill or a fill pattern, and apply a color.

Most gINT symbols are either employed as discrete graphics or fills, described as follows:

e Discrete graphics are not repeated or stretched, appear once at a given location, and are not
intended to fill enclosed spaces. Examples include water level symbols, data markers on curves
in graphs, and borehole markers in site maps.

e Fills are patterns that fill up an enclosed space by repeating or stretching. These include the
following:

o Tiles: These are simple fills constructed from line graphics. They may be used alone, and
also are the main building blocks of composite symbols. gINT ships with over 800
predefined tiles.

o Composite symbols: Composite symbols are fills that are constructed from other fills,
generally tiles, in predefined ways. Material, sampler and well symbols are all composite
symbol fills.

o Miscellaneous fill types: Hatches are rotatable fills that let you duplicate some AutoCAD
fills that you couldn’t otherwise. Bitmap fills are bitmap (dot) graphic patterns rather than
line drawings. Solid fills are as the name suggests. Other than solid fills, you will typically
not use these types either singly or as components of composite fill symbols.

You will learn how to create a basic fill in the Tiles tab, and how to combine tiles into composite
symbols. Note that all composite symbols work the same way, although there are separate Material,
Sampler and Well tabs. This is to keep these segregated, but they are constructed from tiles (and
other basic fill types) in exactly the same way.

You will also learn how to create copies of existing symbols with new names, and caption existing
symbols.

% Note: General symbols, hatches, bitmap fills, and fixed curves on graphs are not covered here. For
specific information on any of these symbol types, see the online help (Help » Index »
fill_type_name). Also, discrete graphics and data markers are not covered. For discussion of the
use of discrete graphics in Discrete Graphic vs Depth entities, see the “Creating Water Depth
Symbols” in the Log Report Design module. For the use of data markers in site maps and site map
reports, see “Customizing the PointIlD Markers” in the Advanced Output Options and Site Maps
module. Use of bitmap symbols or discrete graphics as logos in reports is covered in the appendix
entitled “Adding or Replacing Your Logo in Report Forms.”
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What Fills Do inside a Shape

Let’s experiment with applying some fills and notice how they behave. Do the following:

| 1. Ensure that training.glb is the current library and training.gpj is the current project.

2. Go to DRAWINGS P General Drawings.
3. Select the Rectangle H tool, and create a rectangle with a first point of ‘0,0’ and a second
point of ‘3, 1’ (using the coordinates box at lower left).

4. Select the Rectangle tool again, and create a rectangle with a first point of ‘4,0’ and a second
point of ‘7,3".

5. Select the Zoom Rectangle tool and draw a zoom rectangle that just surrounds the two
rectangles in the drawing. This displays them in a closer view.

6. Double-click on one of the edges of the rectangle at left. The POLYLINE PROPERTIES window

opens.
E POLYLINE PROPERTIES g]
Main | Configurati ] Background FiII] Poinlem]
Remarks ‘ J
Line Type [EfM &
Thickness l:l
Line Color |Black LI

Eill TypellSymbol] | |

Coordinates [DI0I3I0311101 010 .|

| oK | LCancel | Help |

7. Click the Browse *** button to the right of Fill Type[!Symbol] text box. Select a Type of
“‘Solid’ and click OK.

8. Click the Configuration tab. In the Override Fill Color drop-down list, select ‘Very Light Red’.
Click OK.
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10.

11.

12.

13.

14.

SyMBOL DESIGN TUTORIAL

The rectangle appears in solid black. To see its actual color, click the Preview & icon, then
close the preview.

Double-click the left rectangle. Click the Browse button on the Fill Type[!Symbol] text box,
select a Type of ‘TILE’, and a Symbol of ‘LINE30D01” (to go to this symbol in the Symbol
dropdown list, press the ‘L’ key when the list is showing).

Click OK to close the Fill Symbol dialog box, and again to close the POLYLINE PROPERTIES
dialog box. The rectangle is filled with a pattern of diagonal lines. Click Preview to see that
the lines are red, and then close the preview.

Double-click the left rectangle, click the Browse button on the Fill Type[!Symbol] text box,
select a Type of ‘MATL’ and a Symbol of ‘GP-GC’. Click OK to save the fill symbol, and again
to close the POLYLINE PROPERTIES.

Double-click an edge of the right rectangle, and specify the same fill symbol (Type of ‘MATL’
and a Symbol of ‘GP-GC”), then close the POLYLINE PROPERTIES. (We’ll ignore color from this
point on, and not preview). Notice how the symbol is applied similarly in the two rectangles.
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Because of how this symbol is defined, the left 50% of any shape to which it is applied will have
the light pattern, and the right 50% will have the dark pattern.

Double-click the left rectangle, and specify a Type of ‘SAMP’ and a Symbol of ‘GB’, then close
the POLYLINE PROPERTIES. Do the same in the right rectangle.
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Notice that this symbol retains its original proportions as it is made larger.

15. Double-click the left rectangle, and specify a Type of ‘SAMP’ and a Symbol of “‘AU’, then close
the POLYLINE PROPERTIES. Do the same in the right rectangle.

16. Notice that the auger symbol is repeated as you increase the height of the area being filled,
but its components always occupy the same proportions from left to right.

We will see how these kinds of different symbol behaviors, as well as other behaviors, are
configured in a material or sampler symbol, and the tiles from which it is composed.

17. Click the Save icon, and specify a filename of ‘symbols test’. We will re-use this drawing for
additional experiments.

5
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How Tiles Work

A tile is a set of line graphics within a cell of defined dimensions. When applied as a fill to a closed
polyline, the tile is repeated, stretched, or both, in a manner defined in the Mapping property in the
tile’s properties window. In combination, the cell dimensions and the Mapping property defines how a
tile behaves. Let’s look at how some example tiles are defined, and the effect of this when used as a
fill.

Do the following:

1. Go to SYMBOL DESIGN P> Tiles. Select ‘GRAVO01’ in the object selector (open the object
selector list then press the letter ‘G’).

2. Click the Properties Pfj icon. Notice the Name and Description values in the General tab. The
Name property names the symbol, the Description property provides the text that appears
with it in selection lists.

3. Click the Tile Structure tab. Notice that the Cell Width and Cell Height are 0.4", and the
Mapping is ‘Repeat’. Click OK.

4. Go to DRAWINGS P General Drawings, and open ‘symbols test.gdw’.

5. Double-click the rectangle at left, and specify a fill type symbol of Type ‘TILE’ and Symbol
‘GRAVO01’. Close the dialog boxes. Specify the same fill symbol for the right rectangle.

6. Select the Quick Zoom yG) tool and click on the upper left corner of the left rectangle.

7. Select the Rectangle H tool and specify a first point of ‘0, 0.6’ and a second point of ‘0.4, 1°.
This creates a square in the upper left corner with dimensions of 0.4" by 0.4".

8. Double-click in the new square and delete its Fill Type[!Symbol] value (we want an empty
rectangle). This inner square demonstrates the tile cell size and contents.

QUUOUUQ\JUOUU@U
5@@b @@GQBQG
OQUOQOOQOQQOOQ
Di:f@b@i}gb G@[}D QOQGD Q::}GC
OQOOQOQQQQQOOQ{
G(\D @O(\\D @G(\c:: OG(\D @G(\c

9. Notice how the pattern in the simulated tile is repeated to the right and below. The effect is
equivalent to laying square tiles in a rectangular grid on a floor or wall.
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10. Select the Zoom Extent ﬁ? tool to zoom out to show both the left and right rectangles.

11.

12.
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Notice how the gravel tile is repeated uniformly in both the left and right sample rectangles.

This demonstrates a Mapping property value of ‘Repeat’ in a tile. There are other ways to map
tiles into their destination fill area, as we shall see.

Save the drawing.

Tiles that Stretch in One or Both Dimensions

By changing the Mapping property, a tile can be designed to do any of the following:

Repeat the original tile in both directions, without altering size or shape (using the Repeat
setting, which we just demonstrated). This is especially useful for lithology material fills.

Stretch horizontally but repeat vertically (Expand Horz/Repeat Vert). This is useful for vertical
columns of various types, such as drills and well sections.

Repeat horizontally but stretch vertically (Repeat Horz/Expand Vert)

Stretch in both directions, retaining the proportions of the original shape (Maintain
Proportions). This is useful for symbols that you want to enlarge or shrink without distortion,
such as the ‘GB’ (hand) sampler symbol we saw earlier.

Stretch in both directions, distorting the proportions of the original shape to match the
proportions of the fill area (Expand to Fit)

We will demonstrate one of these effects, and how it can be useful.

1.

Go to SYMBOL DESIGN P> Tiles and select ‘GRAVOL’ in the object selector (if not already
selected).

We do not want to make alterations to the existing tile, since it is used in several places.
Instead we will work with a copy. Select File P Copy Page.

7
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In the COPY PAGE dialog box, enter ‘A TEST TILE’ in the Page Names to Copy To box, and click
OK. The new tile appears in the drawing area, consisting of an exact copy of ‘GRAV01’ (both in
properties and drawing objects) except for a different Name property.

% Important Note: Always avoid deleting or altering an existing symbol unless you are
certain you will never need it again in its original form. Instead, make a copy with a
new name, and alter the copy.

Click the Properties P}:j icon, then select the Tile Structure tab.

Change the Mapping value to ‘Expand Horz, Repeat Vert’, and click OK.

Notice that the tile drawing is unchanged. The Mapping value does not affect the original
drawing, just how it is repeated or stretched when filling a region.

Go to DRAWINGS P> General Drawings. Open ‘symbols test.gdw’.

Click on the inner square in the left rectangle to highlight it, and press Delete to remove it.
We will add a third sample rectangle. Select the Rectangle H tool, and enter ‘0, 1.5 for the
first point and ‘1, 3.5 for the second point.

Double-click the new rectangle and specify a fill symbol of Type “TILE’ and Symbol ‘A TEST
TILE’. Do the same for the other two rectangles, and observe the result.
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Not a very useful transformation for this symbol, is it? Let’s see a tile where ‘Expand Horz,
Repeat Vert’ makes sense.

. Go to SYMBOL DESIGN P> Tile. Select ‘AUGERO1’ in the object selector.
. Click the Properties E",:’:j icon, then click the Tile Structure tab. Notice the Mapping is set to
‘Expand Horz, Repeat Vert’. Close the properties window.

. Select File > Copy Page and specify a Page Names to Copy To of ‘A TEST TILE’ (this may
already be the default). Click OK, and answer that it is OK to overwrite the previous tile of
that name.

8
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13. Go to DRAWINGS P> General Drawings and open ‘symbols test.gdw’. Notice how this auger tile
is represented when filling the three different shapes.

In the bottom left rectangle, the pattern appears twice vertically. In the upper left rectangle,
it appears four times. In the square at right, it appears six times. In all cases, the tile is
stretched from side to side so that the shaft of the auger occupies roughly the middle third of
the final fill.

In all three cases, the Mapping value of ‘Expand Horz, Repeat Vert’ in the tile results in a
useful representation of an auger.

9
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Composite Symbols

Composite symbols are fill patterns created from one or more other fill patterns, generally tiles and
solids (although hatches and bitmap fills can also be used). Unlike a tile, whose pattern you draw, you
do not draw a composite symbol. Instead, you compose it by superimposing tiles (or other component
fills), layering them and arranging them from side to side within the symbol. You can control certain
properties of each of the component fills, such as their scaling, color, whether or not vertical borders
appear, and so on.

Let’s look at a material composite symbol, see how it is constructed from tiles, and perform some
manipulations.

1. Go to SYMBOL DESIGN P Material. Select ‘GP-GC’ in the object selector.

E= SYMBOL DESIGN - Material: c:\program files\gint\librariesitraining.glb
File Mavigation Help

i = k=L clse '
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Material | Sampler | Well | General | Tiles | Hatches | Discrete Graphics | Data Markers | Bitmap Symbols | Bitmap Fills | ﬂ

Dwerride Color VYiew Multiplier Legend Position
- 1
[None E | — |
Fill Type[lSymbol] From % To % V¥ertical Borders Scale Hatch Rotation = Owernide Color
elgravi 1] 100 Hone Hone
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. i e
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2. Notice the two rows in the data entry grid. Each of these specifies how one component fill is
used in the composite symbol.

o The first row says to use the tile ‘GRAV01” (which is the gravel tile we used previously). It
will cover the entire horizontal range (0% to 100%) of the area to be filled.

o The second row says to use the tile ‘LINE45D01’, but only from the middle to the right edge
(50% to 100%). A vertical border is also added to the left of the tile, to delimit the left and
right halves of the composite symbol.
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3. Notice the preview area beneath the data entry grid. This displays how the symbol will appear
when used to fill areas with different height-to-width ratios.

4. To see what ‘LINE45D01’ consists of, go to SYMBOL DESIGN P> Tiles, then select ‘LINE45D01” in
the object selector. The tile’s drawing consists of a single diagonal line from the lower left
corner to upper right.

5. Click the Properties F?zj icon, then click the Tile Structure tab. Notice that the cell is .05"
square, which is considerably smaller (1/8th the height) of the ‘GRAV01’ tile we viewed
earlier. The Mapping is ‘Repeat’, which creates a tile pattern like the following:

6. Return to SYMBOL DESIGN P Material. We will make a copy of the ‘GP-GC” symbol and make
some modifications.

7. Select File » Copy Page. In Page Names to Copy To, enter ‘A TEST MATL SYMBOL’, and click
OK.

8. Let’s make the diagonal lines more widely spread apart. To do this, specify a Scale value of ‘2’
in the second row of the grid. This enlarges the tile to twice its actual size in both the
horizontal and vertical.

9. Click the Preview “® putton to see the result at the bottom of the window. (The display is not
automatically refreshed—you have to click Preview.)
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% Note: The View Multiplier field above the grid allows you to preview the final symbol at different
scales. When unspecified, the preview is at 100% (that is, ‘1’ or blank). If you were to enter ‘2’
and preview, you would zoom in. If you were to enter *.5’, you’d zoom out.
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10. Change the Override Color in the second row to ‘Very Light Red’, then preview. The diagonal

11.

12.

13.

lines and vertical border in the right half of the symbol change to red.

RN R L
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Notice that the gravel tile extends all the way across the material symbol, so it affects both
the left and right halves.

Notice also that the closed polyline shapes that make up the gravel tile are not colored in. This
is because the shapes are hollow in the underlying tile. We need a gravel tile with filled shapes
if we want them to be a solid color.

Go to SYMBOL DESIGN P> Tiles. Select ‘GRAV02’ in the object selector. Notice that the
description of this tile in the object selector reads “GRAVEL: SOLID, DIFFERENT SIZES™.

Notice that in the main SYMBOL DESIGN display, this gravel looks the same as ‘GRAV01’. We

need to preview to see its actual appearance. Click the Preview = icon.
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Return to SYMBOL DESIGN P> Material.

Highlight the first row in the grid (the one for ‘GRAV01”) by clicking in the light blue cell to its
left, then press Delete.

Enter values for the replacement gravel tile in the empty bottom row. Click in the Fill

Type[!'Symbol] cell in this row, then click the Browse === button that appears in the cell.
Specify a Type of ‘TILE” and a Symbol of ‘GRAV02’.

In the same row, specify a From % of ‘0, a To % of *100’, and an Override Color of ‘Very Light
Orange’. Preview the symbol. Notice now that the gravel pieces are solid orange.
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You can also create a solid background in the composite symbol. To do this you add a new row
that specifies a solid instead of a tile. In the blank empty row at the bottom of the grid, enter
‘SOLID’ in the Fill Type[!Symbol] cell (a Type of ‘SOLID’, and nothing entered for Symbol),
and an Override Color of “Very Light Gray’.

Preview the symbol. Oops! We’ve turned everything solid gray.

The problem here is that the order of rows in the data entry grid specifies the layer order (also
sometimes called print order) of the component fills, in other words, what prints on top of
what. The order of rows, from start to end, specifies the order of layers from bottom to top—
first row on the bottom, second row on top of that, and so on. To put the gray solid at the
bottom, it needs to be the first row, not the last. And to put the diagonal lines on top, that tile
needs to be the last row.

To reorder rows, you position the mouse pointer in the blue square to the left of the row you
want to move, press and hold down the right mouse button, and drag the row up or down.
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20. Right-mouse drag the ‘SOLID’ row so that it is first in the grid. Then right-mouse drag the

‘LINE45D01” row so that it is last in the grid. Preview the symbol. Now we have the desired
effect.
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21. Click the Save === icon to save the composite symbol.

Tile Colors and Color Overrides

There is a hierarchy of color overrides in the composite symbol and the underlying tiles. This
determines which color setting takes precedence, as follows:

Colors in the drawing objects in the tile take precedence if not overridden in the composite
symbol that uses the tile.

The Override Color setting for a row in the composite symbol’s data entry grid overrides all
colors in all drawing objects in the corresponding tile.

The Override Color field above the data entry grid overrides all colors in all drawing objects in
all layers of the composite symbol, including solids.

To see how this works, do the following:

1.

Select File P Copy Page and specify a Page Names to Copy To value of ‘ANOTHER TEST MATL
SYMBOL’.

Go to SYMBOL DESIGN P> Tiles. Select ‘GRAV02’ in the object selector, if not already selected.

Select File > Copy Page and specify a Page Names to Copy To value of ‘A TEST TILE’. Click
OK, then answer “Yes’ to overwrite the existing tile of this name.

14
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Double-click on the edge of one of the larger drawing objects (gravel grains), such as the one
1/3 of the way from the top and 1/3 of the way from the left. The POLYLINE PROPERTIES
dialog box appears.

B2 POLYLINE PROPERTIES X]

Main | Configuration ] Background Fill ] Pointers ]

Remarks | J

Line Type [Solid |

Line Color |Black ﬂ
Fill Type[!5ymbol] |Snlid | |

Coordinates |I]_1258505350?9205"]_300353535353535"]_1 1 25508350?920?|ﬂ.23?351l |

oK ‘ LCancel Help

In the Main tab, specify a Thickness of ‘0.02” and a Line Color of “‘Medium Magenta’.

Click the Configuration tab, and specify an Override Fill Color of ‘Medium Cyan’. Click OK,
then preview the tile.
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Notice that the gravel grain you altered now has a thick magenta border and a cyan fill
wherever it appears. Close the preview.

Go to SYMBOL DESIGN P> Material.
In row 2, replace the Fill Type[!Symbol] with a Type of ‘TILE” and a Symbol of ‘A TEST TILE’.

5
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In the same row, delete the value from the Override Color field. Preview the symbol.
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Notice that the gravel layer contains black grain symbols except for the one that we filled in
cyan and outlined in magenta. In other words, the gravel tile is being used exactly as it was
created.

Close the preview. In the second row, specify an Override Color of ‘Very Light Orange’.
Preview the symbol.

i S
8 S R

i

Notice that now everything on the gravel layer is orange, including all grain symbols and their
edges.

Close the preview. Specify an Override Color for the entire symbol, at the upper left of the
window, of ‘Very Light Blue’. Preview the symbol.

Not a very useful symbol, is it? What has happened is we overrode the color settings on all
layers, including the solid gray background layer, making everything blue.
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12. Close the preview. Highlight and delete the top row (using the Delete key), then preview
again.
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Now that there is no longer a solid blue layer, the gravel and diagonal lines layers can be seen.
All objects on these layers become blue.

13. Close the preview. Change the master Override Color for the composite symbol to ‘None’. This
restores the colors of the two remaining layers. Notice that the gravel grains are still solid
orange, because we are still overriding the color of the gravel row.
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14. Close the preview. Select File P> Delete Current Page, and click OK to confirm deletion.

%~ Important Note: To repeat our earlier warning, do not delete any symbol that you do
not know for certain to be unused in reports, other symbols, expressions or external
drawings.
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Library Maintenance Options for Symbols and Colors

All symbols and colors are library objects in the current library, and can be copied, edited, and
manipulated, with two exceptions:

e Colors can be copied between and deleted from libraries, but cannot be user-created.
e Line types are internal to gINT, and cannot be added, deleted, copied or modified.

Various libraries of useful symbols and colors are available on the gINT website at
http://www.gintsoftware.com/support updates symbols.html. For example, a library of USGS symbols
is available, as is a set of Munsell soil and rock colors.

To copy symbols or colors between libraries, use UTILITIES P Lib Merge/Copy, and select the
appropriate category or categories in the Available Source Tables list, such as ‘Colors’, “Material
Composite Symbols’, or “Tiles’. Be careful to avoid overwriting symbols of the same name in the source
and destination, unless that is what you really want to do. The Always Query or Query on Overwrite
options are recommended.

Recommendations for Modifying Symbols

Symbol deletion from a library is never a good idea unless you are certain of the origin of the symbol
and that it is not referenced in reports, user system data items, or other symbols elsewhere in the
library. (When you do need to delete, open the symbol in SYMBOL DESIGN and choose File B Delete
Current Page).

Similarly, it is not a good idea to directly modify a symbol in (or obtained from) your standard library,
unless you want your changes to appear for this symbol everywhere it is used. Also, by altering a
standard symbol you run the risk of overwriting your changed version with the original version when
you merge symbols between libraries. A better approach when you want a changed version of a symbol
is to copy the original symbol to a new name (File P> Copy Page) prior to modifying the copy. This way
you can always distinguish the new symbol from the original, you do not risk accidental overwrites
during library merges, and you know exactly where the new symbol is used in reports and elsewhere.

When you want to make the changed symbol more apparent to users than the original symbol in
selection lists in INPUT, you can caption the original symbol. This keeps references to the original
intact in reports and elsewhere, but enables you to make it less obvious in selection lists. For example,
you can caption the original ‘CLS” material symbol as ‘zzz CLS STANDARD’, thereby moving it to the
end of selection lists. You can also caption both the new and original symbols to effectively replace the
original in selection lists (so that the old nhame now selects the new symbol), as in the following
example:

Which Symbol Name Property Caption Property
original CLS zzz CLS STANDARD
changed CLS MY_COMPANY CLS

8
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After these captions are in place, the selection lists will show the following:

CLS

zzz CLS STANDARD

where ‘CLS’ in the list refers to the changed symbol, and ‘zzz CLS STANDARD’ refers to the original.
This works, even though the Caption of the changed symbol appears to conflict with the Name of the
original, because a caption always takes preference over a name in selection lists. Note, however, that
captions only influence the display of symbols in INPUT. In REPORT DESIGN, SYMBOL DESIGN, User
System Data, and so on, you must always refer to the Name, not the Caption, to reference a symbol.

Copying Symbols between Applications

The File P Copy Page option within a particular SYMBOL DESIGN application (secondary tab bar tab)
only copies within that application. That is, you cannot use it to copy symbols from one tab to another.

You can copy composite symbols between the Material, Sampler, Well and General applications using
the File P> Merge option. For example, if there is a Sampler symbol that you wish to copy to the
Material application, click the Material tab and select File » Merge. You see the COMPOSITE SYMBOL
MERGE dialog box.

2= COMPOSITE SYMBOL MERGE

Source Type |EELTENHE Ll ﬂ

Symbol(z] to Merge | | |
Delete Originalls] |

(1] Cancel Help Beset |

You specify the source application in the Source Type list (you’d choose ‘Sampler Graphics’ in the
example), and then select the desired symbol or symbols using the Symbol(s) to Merge field. To avoid
breaking any references to the source symbols from reports and elsewhere, you are advised to leave
Delete Original(s) unchecked. You can rename any copied symbols in the destination application
without harm.

Other SYMBOL DESIGN applications do not have a Merge option. However, you can copy drawing
entities from a symbol in one application to a symbol in another provided both are in line-graphics
based applications, that is, where symbols are created and modified using giDraw. This includes Tiles,
Discrete Graphics, and Data Markers. So, for example, if you wanted to use the ‘BIO_HAZARD’
discrete graphic as a tile, you would create a blank symbol for it in the destination application (Tiles),
open the original in Discrete Graphics, select all the entities (Modify P> Select Entities), copy them to
the buffer, then paste them in the new tile. Note that you will typically need to scale the symbol up or
down in size when copying between these applications, using Modify P Scale Multiply or similar, and
may also need to move the graphic to a different location within the new symbol.

9
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Copying Data Markers to User-Friendly Names

You will notice in SYMBOL DESIGN P> Data Markers in your library, the markers used in graphs and site
maps have names such as ‘1’, ‘4”, 17’ and “82’, which are not very user-friendly. This has been done
for deployment of gINT in non-English languages. However, if there are particular data marker symbols
you use in your own reports or expressions, you should copy the symbols to identical versions with user-
friendly names. For example, if you copy the marker ‘3’ to one called ‘BH_MARKER’, marker ‘16’ to
‘TP_MARKER’, marker ’17’ to ‘CPT_MARKER’, and ‘1’ to ‘DEFAULT_MARKER’, you could write the
following site map PointID marker expression:

<<Switch(<<Like(<<POINT.PointID>>,"B-*")>>,3,
<<Like(<<POINT.PointlID>>,"TP*")>> 16,
<<Like(<<POINT.PointlID>>,"CPT*'")>>,17,
True,1l _

)>>

as this one instead:

<<Switch(<<Like(<<POINT.PointlD>>,"B-*"")>>,BH_MARKER, _
<<Like(<<POINT.PointID>>,"TP*")>> TP_MARKER, _
<<Like(<<POINT.PointlID>>,"CPT*")>>,CPT_MARKER, _
True,DEFAULT_MARKER _

)>>

Captioning will not work in this circumstance, because you’re trying to provide user-friendly names to
persons doing report design and similar development work, rather than to end users. The actual hame
of the symbol, not a caption, is what is referenced by a report or expression. Similarly, it is not
advisable to rename the original symbol, because it may already be in use by an existing report or
expression. For these reasons, you should copy, not caption or rename, frequently used data markers,
then give the copies user-friendly names.

0
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Appendix A -- Adding or Replacing Your Logo in Report
Forms

We have configured the report forms that are supplied with gINT to obtain your company information
and logo from a block. Blocks in gINT work the same way as in other drawing applications. They are
drawings that are referenced by other drawings.

Any change you make to a block is reflected in all the drawings that are referenced by it. Therefore,
you will only need to place your logo in one drawing for it to appear on all the forms. If you encounter
any problems adding your logo, please contact gINT Technical Support.

Importing Your Logo

The first step is to store your logo in your gINT library. The logo can be stored either as a vector (HPGL
or DXF) image in SYMBOL DESIGN » Discrete Graphics, or as a bitmap (BMP, JPG, TIF, etc.) image in
SYMBOL DESIGN » Bitmap Symbols (not Bitmap Fills). You could draw your logo in gINT in either
location, but it probably already exists in electronic format.

If you have the option, we recommend using a vector image to store your logo, since this can be
exported to DXF format and bitmaps cannot. Vector images are created in applications such as
AutoCAD®. gINT supports AutoCAD version 12 DXF format; if you have a later version of AutoCAD, save
the file as a version 12 DXF.

To import a Discrete Graphics logo:

1. Go to SYMBOL DESIGN and click the Discrete Graphics tab. Select File » New or click the New

]

button. You see the New... dialog box:

ﬂﬂme| |
LCaption | |
Description
Page Size [Letter (8.5 x 11 in.] =]
Orientation |Purtrait ﬂ

(1] Cancel Help

2. If there is any data, click Reset to clear the fields. Enter a Name and if desired, a Description.
Accept the default values and click OK.

3. Select File » Import/Export » DXF Import. Navigate to the location of your DXF logo file and
click Open. The program imports the file and displays it on the screen. You will control the size
and placement properties of the logo when you place it.

1
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To import a Bitmap Symbol logo, do the following:

1.

Go to SYMBOL DESIGN and click the Bitmap Symbols tab.

Select File » New or click the New D button. In the dialog box that displays, enter a Name
and if desired, a Description.

Click the browse IZ' button next to the Load Bitmap File field and navigate to your logo file.
You can import any of the following image formats: JPG, BMP, TIF, PCX, PNG, PPM, or TGA.
Click OK to import the file.

Placing Your Logo

To place your logo:

1.

Go to the DRAWINGS tab and click the Drawing Library tab. Select ‘COMPANY INFORMATION’
from the drop-down list, if it does not appear by default. You see a screen similar to the
following:

= DRAWINGS - Drawing Library: c:\program files\gint\libraries\gint us.glb
File FBlocks Edit Draw Modify Text Polyline Miew Assist Settings Mavigation Help
s & [ [COMPANY INFORMATION
INPUT | DUTPUT | DATA DESIGN | REPORT DESIGN | SYMBOL DESIGN DRAWINGS |UTILITIES
Drawing Library
I | =
o Ao
| i i
| i
I I A S
! I 2 I =
! I OO0 @
1 1 & 6™u 9
| @
| *company hame & 2
| address
3 -- Lo O- - fEity; statepostalcede - —---—- - - - oo T
| o9 ¥ statep SR
: phone — wuy
: fax*
L o] pe i o
o
LLP
RS
yol
fd
4] « s | e
2 N e et e R le [polyline] i
= lo:o * \A{ T 3{ l 3 Select Entities 2
K=3 40173 Y=1 20066 Refresh ]
J

Note: If you have gINT Logs, the General Drawings tab does not appear.

Click on the word “Logo”. When selected, the text will turn green:
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2} DRAWINGS - Drawing Library: c:\program files\gint\libraries\gint us.glb
Fil= EBlocks Edit Draw Modify Text Polyline Wiew Assist Settings Mavigation Help

|
|
|
|
|
|
i
‘ .
| *company hame &
| address
. ‘( E
! - L’O’QO* “eity; state-postalcede — -~ - - - - - ; £ f:
! phone | a
} fax*
L o o pd i oF
)
Lpp
LB2
|2
[ jm% i3 1ol
= SELECT ENTITIES Cancel
Select Entities Erase Move Copy ‘ Zoom
‘ copy to Buffer cUt to Buffer

From the options that appear on the lower right section of the screen, click Erase.

Select either the Draw » Graphics » Discrete Graphics or Draw » Graphics » Bitmap
Symbol option, as appropriate:
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22 DISCRETE GRAPHICS PROPERTIES

Table Field Paste System [temns Pazte

|EHEEKED BY ﬂ |Name ﬂ |Functiu:uns ﬂ |.l’-'-.l'-‘l.SHTEI_GrDup_In j

Main l Configuration ]

Bemarks J

Dizcrete Graphic | | |

Owerride Height |:|
Overide Width [ |
Ovemde Horz Align | Default -

Ovemde Yert Align |Default b

[ ]
[ ]

Angle |

=[x

Overide Color [Hone

Dezign Mode Color |Nune

2= BITMAP SYMBOL PROPERTIES

T ahble Field Paste System Items Paste

|I:HEI:KED BY ﬂ |Name j |Functiuns ﬂ |.t'-‘n.-’-'~5HTEI_Gru:|u|:u_In j

Main l Configuration ] Border ]

Bemarks J

Bitmap Symbol | | |

Owverride Height I:l
Overide Width |:|
Override Horz Align m
Override Yert Align m

[ ]
[ ]

Angle Expression

[~ X

Show at dezign time [

oK ‘ Cancel | Help

Set the X and Y fields to “0”.

Click the browse button IZI next to the Discrete Graphic or Bitmap Symbol field and select
your logo.

4

gINT Software, Inc. —&  www. gintsoftware.com



SyMBOL DESIGN TUTORIAL

7. Set Override Height to 0.9 (this equals the height of the square in the drawing). Set Override
Horz Align to “Left” and Override Vert Align to “Middle”.

8. For a Discrete Graphic, set the Design Mode Color (this setting does not affect the final output
color) to “Very Light Blue” (this is a gINT standard; please feel free to use any color you wish).

9. For a Bitmap Symbol, check Show at design time. If unchecked, the logo is only displayed on
the form when it is previewed or printed.

10. Click OK to place the logo.

If the width of your logo is significantly larger than its height, it will overlap the Company Information
text. To correct this, you need to change the logo height or width and/or the X property of the
Company Information text entity. To display an entity’s properties, double-click on the desired entity.

Not Using a Logo

If you do not have a logo to add, follow the instructions for placing your logo. After erasing the “Logo
text, double-click the Company Information text and set the X property to “0”. This aligns the
Company Information text on the upper-right portion of the form.
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