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MICROSOFT EXCEL OPTIONS IN gINT

gINT and Microsoft Excel®

gINT is feature-rich and sophisticated enough to handle virtually any task. This reduces the need to use
an external program. However, no one program can handle all your needs and certain tasks are best
handled with different software. Therefore, we have designed gINT to be compatible with many
industry-standard applications.

To this goal, we have incorporated a multitude of methods into the program for interfacing easily with
Microsoft Excel. These links strengthen the individual capabilities of both programs and enable users to
work in the most efficient environment to meet the specific needs of each project.

gINT is packed with ways in which you can work with Excel data. gINT and Excel should not be seen as
mutually exclusive programs but rather as complementary data handling software.
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MICROSOFT EXCEL OPTIONS IN gINT

Overview of Links with Excel

gINT provides the user with many options for working with data in Excel. Whether it is bringing data in,
or exporting it out, there is a feature in gINT that will complete the task for you. Some processes are
more complex, such as writing a gINT Rule, or building a detailed query.

Others require only a drag of the mouse and the click of a button, like the new feature in gINT Version
8 that allows you to select grid data and copy and paste it directly into an Excel spreadsheet. It doesn’t
get any easier than that!

INPUT Import/Export Options - Your entire gINT project, or selected tables and boreholes can
be directly exported to, and imported from, Excel.

Text Tables - Text Tables can be configured in gINT to create customized tabular output of any
data, including calculations or manipulations of that data, for export to Excel. Text Tables
narrow down the scope of the export to include just the required data for a particular
application. These reports, like all others in gINT, are created once and used on any project.

Queries - You can use Structured Query Language (SQL) expressions to extract specific data for
export to Excel.

gINT Rules Code - One of the more advanced features of the program, gINT Rules, can be used
to read or write directly from Excel or execute a command which uses the native gINT facilities
to import or export data from and to Excel.

Copying/Pasting from Grids - This is the quick and easy way to move data between gINT and
Excel. Just highlight the data in a grid and copy/paste it into Excel, or visa versa.

The List Feature - All List dialog boxes in gINT contain an Export button that allows you to
instantly export the displayed data to an Excel spreadsheet.

Library Data Import/Export Options - Non-project specific Library Data offers import/export
options for Excel, and because it is a grid-style screen, you can move data between the
applications with little or no formatting changes.

AGS Export Option - gINT contains an Edit AGS File in Excel option in INPUT to enable AGS
files to be modified and the file recompiled from the spreadsheet.

DATA DESIGN Import/Export Options - You can export project database information from
DATA DESIGN to Excel using the File » Export to Excel File menu option.
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Exploring gINT's Excel-Related Features

Let’s take a closer look at how gINT can interface with Excel. The following sections describe each of
the Excel import/export features available in gINT, and provide an example using applicable sample
data.

INPUT Application Import/Export Options

The INPUT application group contains import/export options for moving and manipulating data
between gINT and Excel. Use the File » Import/Export » Import from Excel File menu option to
import data from Excel into a gINT project database (.GPJ file).

When you select the menu command, the Import from Excel File dialog box is displayed:

E= IMPORT FROM EXCEL FILE

Excel® File | =

Cormrezpondence File | | |

Owerwrite Options |Never ﬂ

(1] Cancel Help Beset |

The dialog box contains the following import options:

o Excel File: Enter the file name that you are importing the data from or click the browse IZ'
button to navigate to the file location.

e Correspondence File: A correspondence file informs the program of the relationships between
the tables and fields in the source file and the tables and fields in the target file. When
importing from Excel, you can use this type of import structure to supply non-default values in
the source data and to provide default values where the source field is empty. Or you can have
a correspondence file write a default value into a field. Correspondence files are also a good
tool for converting the structure of an existing Excel database to a gINT database.

e Overwrite Options: This field controls how the program handles data in both the current
database and the external file you are importing.

You would select:

e Never - To add records whose keys fields do not exist in the current gINT database. Existing
records are not modified. Any overwrite option you select will apply this behavior to new
records.

e Empty Fields - To write data from the source file only if the corresponding field in the target
file is empty.

3
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e Named fields - To write data from a field named in the source file wherever a matching field
exists in the target, overwriting the contents of the target field. If a field is empty in the
source file, the program will overwrite any contents in the target field and leave it blank.

e Records - To erase each target record matched by a source record (same key) and write the
data from the source file. Any records in the target file that do not have corresponding records
in the source file are not affected by the import.

e Data sets - To replace entire sets of data. The resulting gINT data set will contain only data
from the source file. A "Data Set" is defined by the key set of the parent table. For example, in
a table with the PointID,Depth key set, a Data Set is all records with a particular PointID value.

When you are ready to import the data, click OK. You briefly see a screen displaying the import
progress:

Importing testone. xls

Cancel
| 9 Writing Temporary file.
| [ Table FHK READINGS

When the import process is complete, gINT displays the import log file detailing the status of the
imported data:

qINT Import/Herge Log 5/23/2886 9:13:35 AW A~
Source File: c:yprogram files\gint8itestone.xls
Target File: c:\program files\gint8\temp\projectsoldigint us lab.gpj

471 Records imported.

SOURCE:

PROJECT: 1 records oK.

POINT: 18 records ok.

LABE SPECIMEM: 41 records oK.
SAHMPLE: 26 records ok.
LITHOLOGY: 42 records ok.
WELL: 18 records ok.

REHARKS: 2 records ok.

CPT: 463 records oK.

WC DEMSITY: 38 records oK.
ATTERBERG: 28 records ok.
SIEVE: 30 records ok.
HYDROMETER: 2 records ok.
FINE 5G: 1 records ok.
COMPACTION: 1 records ok.
UHGONF COMPR: 1 records oK.
CONSOLIDATION: 3 records ok.
DIRECT SHEAR: 1 records ok.
FALL HEAD K: 2 records ok.
ATTB READINGS: 22 records ok.
SU READINGS: 141 records ok.
HYD READINGS: 28 records ok.
FINE SG READIMGS : 4 records ok.
COMP READIMGS: 18 records oK.
UHC READIMGS: 14 records oK.
COMSOL READINGS: 74 records ok.
DSHR READINGS: 3 records ok.
FHE READINGS: 12 records ok.

e Heln | Print | Save b |

Click OK to close the dialog box, Print to print the information on the screen, or Save As to save the
file as a text file.
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The File » Import/Export » Export to Excel File menu option displays the Export from Excel File
dialog box:

E= EXPORT TO EXCEL FILE 3

Excel® File | .

Usze Commezpondence File

All tables 0«
Selected tables

Current Screen only

Select Points | | |

Structure only
Hetain format codes
Include field Captions

Separate Files for each Workzheet

H NN e

Launch Excel® after export

(114 Cancel Help Heset

The Export to Excel dialog box has many useful options that can assist you in manipulating your data
into the desired format for exporting to Excel.

You would select:

e Excel File: To enter the name and location of the final Excel output file.

e Use Correspondence File: To enable the Correspondence File field, where you can specify
the name and path of the Correspondence File to use. See the Correspondence File field
description of the Import to Excel dialog box properties, above.

e All Tables: This option to export all the tables in the currently project file.

e Selected Tables: This option to export selected project database tables. When you click this
field, the Select Tables option becomes available for you to select the tables to export.

e Current Screen Only: To export only the data from the currently displayed table.

e Select Points: To supply the list of PointIDs to be exported. If left blank, all PointIDs are
exported.

e Structure Only: If you did not want to export any data, only the Table and Field structure of
the database. You can then use the export file as a starting point for data import. This is useful
if you want to import data from an existing spreadsheet file. For example, if you receive
Geophysical data from a logging company in an Excel file that you want to import into your
existing project file.

e Retain Format Codes: To keep the gINT formatting codes (such as <<B>>, <<U>>, and so on)
embedded in the final data output.

e Include Field Captions: To place any field captions under the actual field names in the Excel
file. This allows for easier data entry when exporting to spreadsheet (like Excel).
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e Separate Files for Each Worksheet: To create separate Excel files for each worksheet, instead
of separate tabs in one Excel file. Normally, when you export to an Excel file, the data from
each table in your project database is saved in a different worksheet (or tab) in the Excel file.
This option is helpful when exporting files that will be imported by programs requiring each
worksheet to be a separate file.

e lLaunch Excel After Export: To open Microsoft Excel after the export process is completed.

The INPUT Excel import/export options allow users to configure and modify their data to achieve the
final output format of their choice and maximum target/source file compatibility.

Using Text Tables to Import/Export Excel Data

Text Tables are reports that present tabular summaries of data. This is very useful for
importing/exporting to Excel because there are no formatting issues to deal with and makes data
exchange a straightforward process. To create a new text table report, open REPORT DESIGN and click
the Text Tables tab.

Select File » New, press CTRL+N, or click the New icon to display the New... properties dialog
box. Click the Report Structure tab to define the properties specific to Text Table reports.

E= TEXT TABLE REPORT PROPERTIES (]
Table Field Pazte Spgtem [tems Paste
|CHEEKED B ﬂ |Name j |Functi0ns j |MSHTEI_Gmup_In ﬂ

General HReport Structure ]

Max. Humber Page Header Lines I:I
Max. Humber Page Footer Lines I:I

Consolidate Bows [

oK | LCancel Help
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MICROSOFT EXCEL OPTIONS IN gINT

The values entered in these fields must be greater than or equal to the actual header/footer lines
specified in the report. The value in the Max. Number Page Header Lines is specific for the page
header. The column headers are specified in the report body and the number of column header lines
are determined from the column headers. If you click OK, you see a screen similar to the following:

B= REPORT DESIGN - Text Tables: c:\program files\gint8\gint us lab.glb
File Edit Format Mavigation Help

=1 |_] (A [er summary =]
INPUT | DUTPUT | DATA DESIGN REPORT DESIGN |SYMBOL DESIGN | DRAWINGS | UTILITIES |
Logs | Fences | Graphs | Histograms | Graphic Tables Text Tables |Graphic Text Docs| Text Docs | Site Maps |
[~ Separate Sets Table Field Paste | Spstem Items Paste
[CHECKED BY ] [Mame ~| [Functions | [24SHTO Group In ~|
Page Header

Project: <<PROJECT.NHame>>
Location: <<PROJECT.Location>>
Humber : <<PROJECT.Number>>

Body Columns

Header Text Output Condition Data Expression Format ‘Width Align Wiap Depend ~

Borehole <<PointiD>> 10|Left

m] ]
Depth <<Depth>> 0.0 8| Right

m] ]
Liquid <<Let[¥alue = <<ATTERBERG._Liquid_Limit>>]>>_ 8| Right
Limit <<User System Data Atterberg_Calc>> [m} [}
Plastic <<Let¥alue = <<ATTERBERG.Plastic_Limit>>)>>_ 8| Right
Limit <<User System Data Atterberg_Calc> > [} [}
P <<User System Data.PI_Calc_Single>> 8| Right

m] ]
Maximum <<RoundTo(<<Max(<<5¥ READINGS. Reading>>)>>.0.001)>> 8| Right
Size m] ]
(mm) § ; ~

Fow 1
of 12

Page Footer
<<r>>Sheet <<Pg>> of <<NPgs>> ‘

<<ReportID>> <<ProjFile>> <<DataTemplate>> <<Format{<<Now>>,<<FdNUmMS1lash>>)>>

The report itself is broken down into a multi-line text box for the page header, a grid for the column
headers and body, and another multi-line text box for the footer. If you leave the Separate Sets option
unchecked, all the data lines will print one after another. If checked, the report will start a new page
for every set of data.

The table body is specified by a series of grid rows, with each row specifying a column on the final
output. By defining the table properties, such as Output Condition, Data Expression, and so on, you
can manipulate the data that you want to print on the report. You can then output the report (in the
OUTPUT application group) to an Excel file.

Using Queries to Generate Excel Data

If you have some knowledge of SQL (Structured Query Language), you can create reports that filter on
specific data quickly and easily using the INPUT application’s Query feature. Queries are stored in your
library, not in the current project, so you can use a query with any project. You can also import and
export queries using the Lib Merge/Copy application in UTILITIES.

Select Tools » Queries to display a list of existing queries or to create a new query. You see the Query
List dialog box:

7

gINT Software, Inc. —&  www. gintsoftware.com



MICROSOFT EXCEL OPTIONS IN gINT

E= QUERY LIST

| Name | Description

MHew
Row 1

Erecute | Edit Eriht | Export |
oK I Cancel l Help

To create or edit a query, click the Edit button at the lower left of the dialog box.

You see an expanded window containing the Data Tool:

E= >Unnamed= |‘El
Table Field Paste I
IF'FHEIJEI:T d ]Client j
Ok | Cancel Help Frint Erecute

Once a SQL expression is written, it can be executed by clicking the Execute button on either the SQL
edit window or the Query List dialog box. The query is executed against the currently open project.

Executing a successful SQL expression displays a grid dialog box with your field headers shown above
the results columns. If you just selected fields, the field names will appear, unless they were
captioned, in which case, the captions will appear. From the query results screen, you can print or
export to an Excel file.
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gINT Rules and Excel Data

gINT Rules Code allows you to write programs in gINT. Please by aware that this is programming and
you must be a programmer to use this facility. Using gINT Rules Code, the first step is to write code

procedures within a module or modules, and then assign the procedure to the gINT Rules Procedure
property of the applicable table in DATA DESIGN.

gINT Rules can be used with Excel in two ways:

e Native gINT commands can be invoked to run queries, perform Excel import and export, and to
export to Excel via Text Table reports.

e Procedures can be written that access the Excel object for direct manipulation of Excel
spreadsheets.

gINT Rules are created in INPUT, using the gINT Rules » gINT Rules Code menu option.

When you select the menu command, the gINT Rules Editor is displayed:

B2 gINT RULES CODE

List | Cods |

Module HName Description

e
Row 1

Procedures | Frint | Expart |
Lock | ok LCancel Help
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The List tab displays all the modules defined in the current library, and the Code tab is where you
write the actual program code.

E= gINT RULES CODE - Al=3
Edit Wiew Macro Debug Help
List Code |

T M o | » 5= [=
Object: |[Eeneral] ﬂ Proc: |[dec|alatiuns] ﬂ
Option Explicit

| ™
b

Erint | wirite ta File | Save | Donhe | Help |

Once the code is written, it must be assigned to a table in DATA DESIGN. You would open DATA DESIGN,
and from the Project Database tab select the database you want to assign the gINT Rules procedure to.

Then select the appropriate table from the object selector drop-down list, click the Properties
icon and select the gINT Rules tab. You see a dialog box similar to the following:

E= DATA TABLE PROPERTIES

General gINT Rules '

gINT Rules Procedure on Empty Dataset ||

gINT Rules Procedure on Save

glNT Rules Procedure After Save

gINT Rules Procedure Leaving table | | J

oK LCancel Help
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This is where you would assign the procedure that you wrote in INPUT. gINT Rules is a powerful tool

within gINT, and can be used to create extensive and complex commands to exchange data between
gINT and Excel.

Copying and Pasting Data from Grids to Excel

While gINT Rules is an advanced method of working with data, the copy/paste feature available from
Version 8 on is the simplest and most convenient way to move selected data between gINT and Excel.

You can perform the copy and paste from any grid screen in gINT. For example, from the INPUT
application, open a project database file and select the tab you want to copy the data from.

Highlight the data by dragging your mouse across the appropriate cells:

B2 npuT - c:\program files\gintB\empiprojectsoldigint us lab.gpj: SAMPLE table Library: c:\program ... g@@
File Additional Modules Edit Format Tools Tables  gIMT Rules  Mawvigation Help

= WS EE I W= = N = G 1
INPUT |DUTPUT | DATA DESIGN | REPORT DESIGN | SYMBOL DESIGN | DRAWINGS | UTILITIES
Main Group |5ile Map | Lab Testing | Surfaces |

Project | Borshole  Sample | Lithology | el | Remarks | Cpt|  Sample Database |

Table Help

Depth | Length Type MNumber Recovery HROQD Blows Blows Blows @ Blows Pocket PID Other
[[{d] [in]) Length | Length 1st 2nd 3rd Ath Penetrometer [ppm] Tests
(in) (in]

[t=F)
24|55

| 5 9 12 14
o 22 — IS—
24(sT - 1 j uc-14m
9 1
4+ 18 1 12
185 18(S5 16 13| 13
9/55 5 75
52

60|RC 48| 20
60[RC

40 60 RC |R3 55

Row 9
of 9

Press CTRL+C or right-click the mouse and select Copy from the menu that is displayed. Open Excel,

select the desired file and press CTRL+V or Edit » Paste to paste the selected data into the
spreadsheet.
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=13

E3 Microsoft Excel - Book1

E_] File Edit W¥ew Insert Formak Tools Data  Window Help  Adobe FDF Type a question For help = o & X
NEHRSRVE| SRR S 98 A2 G -
: Aial 10 - B I U|E=E=E]8 % 0 G0
Al i & 1

= TR E I m T E IEE O E R e e e
| 1 ] 1 ZEEs 1 i) 5 = 12 14 MND ;
] 5 24 5T 2 11 0.8 8
-3 | 10 18 55 3 18 =l i) 15 7
4] 14 18 55 4 18 11 12 15 15
| 6 | 184 18 33 2] 16 13 13 27 22
| B | 25 9 55 B 5 25 55 MND
g 30 B0 RC R-1 48 20 MND
| & | 35 B0 RC R-2 52 30
g 40 B0 RC R-3 55 36
2]
[
14 ]
s
ET=S B
4 4 » v} Sheetl /sheet? / Sheet3 / it N
Ready Sum=1121.3 UM

You can also reverse the process and select data in Excel then copy and paste it into a gINT grid
screen. Note that when pasting from Excel to gINT, you may be pasting 100 rows of data but the gINT

grid has only one empty row. Just paste, gINT will create the required number of rows.

Using List Screens to Export to Excel

All the List screens in gINT contain an Export option that you can use to export the displayed

information to another format, and specifically Excel if that is your choice.

For example, in INPUT, if you click the List

| button, you see a dialog box similar to the following:

gINT Software, Inc.

Y

www. gintsoftware.com

Hame Caption Hide Description Group Parent Date cln
| CONSOLIDATION [ |Consolidation Test: Parent table |Lab Testing |LAB SPECIMEN B/772004 7:41:11 AW i
CPT (] | POINT 2/15/2006 12:54:59 PH
DIRECT SHEAR O Direct Shear Test: Parent table |Lah Testing |LAB SPECIMEN 8/8/2005 3:58:40 AM
DSHR READINGS 1], Direct Shear Test: Headings Lab Testing |DIRECT SHEAR 4/20/2000 7:27:12 AM
FALL HEAD K O Falling Head Permeability: Parent table Lab Testing |LAB SPECIMEM 472072000 7-31:45 AM
FHK READINGS O Falling Head Permeability: Readings Lab Testing |FALL HEAD K 472072000 7:31:45 AM
FIME 5G O Fine Specific Gravity: Parent table Lab Testing |LAB SPECIMEM 8/8/2005 3:58:27 AM
FINE 5G READINGS =] Fine Specific Gravity: Readings Lab Testing |FINE 5G 472072000 7-23:48 AM
HYD READINGS [ |Hyd Analysis: Readi Lab Testing | HYDROMETER 4/20/2000 7:22:53 AW
HYDROMETER O Hydrometer Analysis: Parent table |Lab Testing | LAB SPECIMEN 8/8/2005 3:58:28 AM
LAB SPECIMEN 1=] |Lab Testing |POINT 4/20/2000 7:19:16 AM
LITHOLOGY 1] POINT 1172472002 1:24:04 PH
PDINT Borehole I 5/2/2006 1:03:38 PM
PROJECT O 11/23/2002 4:23:25 PH
REMARKS O POINT 5/3/2006 8:23:16 AM
SAMPLE I C POINT 2/15/2006 12:55:12 PM
SAMPLE DATABASE = POINT 5/3/2006 10:17:14 AM
SIEVE O Sieve Analysis: Parent table |Lab Testing | LAB SPECIMEN 8/8/2005 3:57-49 AM
S5¥ READINGS O Sieve Analysis: Readings |Lah Testing | SIEVE 8/8/2005 3:57:50 AM
UNC READINGS O |u fined C: Striength: Readi |Lab Testing |UNCONF COMPR 11/5/2000 3:20:21 PH 2
HacANE FAann = oo A .. Fao— k. Po_——iebio 1 L T .- i &R cArcnarug FITIAnRL ToadAn AL > £
‘ Raw 21
of 28
Curent | [SAMPLE Frint Export
ok Cancel Help
2
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The screen displays all the tables in the current project file. If you click the Export button on the
lower right corner of the screen, you see the Export To a Text or Excel File dialog box:

Export to a Text or Excel® file

Save in; |E}QINTE j IiF "
_5 ICbin
: Iy datatmpl

ty Hecent Ihdocs
Documents 3 drawings

'_T'- Eprujects
[hscripts
Dezktop (ytemp
: |3 Training
-.J @l_a]test.csv

My Documents

by Computer

@

My Metwork  File name: |Sample.:-cls j \il

Places
Save as lype; |E:-:n::e|® format [ xlz) ‘wa Cancel |
| Comma delimited [C5V] * cav

E wel® farmat [ =ls]

Enter a name for the Excel file and select “Excel format (*.xls)” for the Save as Type. Click Save to
save the file. When you open the file in Excel, the table data from your gINT project file is displayed:
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Microsoft Excel - sample.xls E|@|Pz|
E‘_W File Edit \Miew Insert Format Tools Data  Window Help  Adobe FDF -3 X
NEEA 3SR VSRR S o-8x-s R g -eN

: Arial -0 - B 7 U|EEEH$ % o |E S-A-EERTEET N

Al - = Mame
A 3 [ 5] D [ E T &

1 |Mame Caption |Hide Description Group Pare

2 |ATTE READINGS 0 Atterberg Limits: Readings Lab Testing ATTI

3 [ATTERBERG 0 Atterberg Limits: Parent table Lab Testing LAB

4 [COMP READINGS 0 Compaction Test: Readings Lab Testing (GO

5 [COMPACTION 0 Compaction Test: Parent table Lab Testing LAB

6 [COMSOL READINGS 0 Consolidation Test: Readings Lab Testing COM

7 |[COMSOLIDATION 0 Consalidation Test: Parent table Lab Testing LAB

g8 |CPT 1] ]

9 [DIRECT SHEAR 0 Direct Shear Test: Parent table Lab Testing LAB
10 |DSHR READINGS 0 Direct Shear Test: Readings Lab Testing DIRE
11 |[FALL HEAD K 0 Falling Head Permeability: Parent table Lab Testing LAB
12 |[FHK READINGS 0 Falling Head Permeability: Readings Lab Testing FAL
13 |[FINE 5G 0 Fine Specific Gravity: Parent table Lab Testing LAB
14 |[FINE SG READINGS 0 Fine Specific Gravity: Readings Lab Testing FINE»
M 4 » W PROJECT DATA TABLES / |< >
Ready T

Library Data Import/Export Options

The Library Data application in DATA DESIGN offers import/export options for the Excel file format.
You can export data from an existing library table or import data from an Excel spreadsheet into an
empty table and then work with the data in gINT.

If you click the Library Data tab in DATA DESIGN, you see a screen similar to the following:

4
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= DATA DESIGN - Library Data: c:\program files\gintBlgint us lab.glb E =X
File Edt Format Tools Tables gINTRues Navigation Help

=2
= = (2] [FYDROMETER CALIBRATIDNS =]
INPUT | DUTPUT DATA DESIGN |[REPORT DESIGN | SYMBOL DESIGH | DRAWINGS | UTILITIES
Project Dalahase] Library Tables Library Data |Lnnkup Lisls] Readings Lisls] User System Dala] Cormrespondence Files_

Data Template

Table Field Paste | Spstem Items Paste I
|EHECKED BY ] [Name =] [Functions =] [#4SHTO Group In ~]

Table help

Slope i ion 2ndOrderTerm
13.15383 -0.3816289 14 July 1998

Fow 1
of 1

Select File » Import/Export and choose an option, either Export to Excel File or Import from Excel
File. If you select the Export option, you see a dialog box similar to the following:

E= EXPORT TO EXCEL® FILE

Excel® File | ||

Current Page Only +
All Pages
Selected Pages

Page List | |_|

Launch Excel® After Export [

[1]4 LCancel | Help | Beszet |

This screen is similar to the INPUT Export to Excel File screen but with fewer properties. Enter the file
name or click the browse button to select a file to export the data to. You can export the current
library data table (Current Page Only), all tables (All Pages), or select a specific table (Selected
Pages).

If you click Selected Pages, the Page List field is activated and you can select the data you want to
export from a list of all the library tables. When you are ready to export the data, click OK. You can
then open Excel and view the exported data:
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B3 Microsoft Excel - sample.xls |Z|@|E|
EI_] File Edit Wiew Insert Format Tools Data  Window Help  Adobe PDF SR
HAR=R" RIS NN A - S TN - SR A RN Rl RS TR (N1 W RN
: arial v1n-|BIg|§§§§|$%sIE?IEv&-é-EE‘@@ﬁ!
A1 - B HydrometerlD

A B | © | D | E | F =
1 |HydrometerlD iType | Termperature_Units | Calibration_Intercept  Calibration_Slope | Calibration_2ndOrderTerm
2 |US DEMO  1M152H C 13.15383 40.3816289
3
4
5
= v
M 4 » M\ HYDROMETER CALIBRATIONS / < | |
Ready LI

The AGS Export Option

You can edit AGS files in Excel using the File » AGS Files » Edit AGS File in Excel option in INPUT.
You see the following dialog box:

E= EDIT AN AGS FILE IN EXCEL

AGS File | ... ]
Data Structure In Excel® |F3 R E ENT N o0 1| 22 e h

Conzolidate <COMT> hines [GUNEIERLRL AT T
Each datazet in a zeparate worksheet

(1] Cancel | Help | RBeset |

Enter the name of the AGS file or navigate to the file location using the browse III button. Next,
select an option for formatting the data in Excel.

Select All data in one Worksheet top place to keep all the AGS data in one Excel worksheet, or Each
dataset in a separate worksheet to place each AGS group in its own worksheet and name the
worksheets by the AGS group.

Check the Consolidate <CONT> lines option to combine continued heading, units, and data lines into
one line so that there are no continuations. If you wish to edit the file in Excel, you must check this
option. The program will not recreate the AGS from the Excel spreadsheet if it is unchecked.

To facilitate editing, checking the Each dataset in a separate worksheet option for the data structure
makes finding data and adding new rows easier. While you are working in the Excel spreadsheet, you
will not be able to access gINT.

If you check Consolidate <CONT> lines, make changes in Excel, and then save the file, when you
return to gINT, the program recreates the original AGS file using the new data.

6
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DATA DESIGN Import/Export Options

The DATA DESIGN application group has an Export to Excel File option on the File menu that can be
used in the Project Database, Library Tables, Lookup Lists, and Reading Lists applications. Like the
Excel Export option in INPUT, you can name the output file, specify which pages to export, and launch
Excel after the export process is complete.

7
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Using the Excel Database Query Facility

Excel supports database import through user-defined queries. This is similar to the gINT Query method
described above but it has a “wizard” interface that walks you through the process.

To access this capability, in Excel select the Data »Import External Data »New Database Query
menu.

Choose Data Source @

Databaszes l Dueries] OLaP Eul:nes]
<Mew Data Source:

dBASE Files® ﬂ
Excel Files®

|omega Automatic Backup Pro® Erowse...
M5 Access Databaze”

riydatasources Options. ..
PostareSOL

Yizual FoxPro D atabase® elete
Vizual ForPro Tables” -

@ W Usze the Query Wizard to create/edit queries

In this dialog you would select the “MS Access Database” option and a file open dialog will appear.
Although gINT uses ACCESS files to store its data, it does not use the default “MDB” extension. gINT
projects use a “GPJ” extension. So in the file open dialog you would change the file type to “All Files”.

For the rest of the process, please see Excel Help (search for “Database Query”) or perform a search on
the Internet (search for “Excel Query” or related topics).

In the end you can import whatever data you wish directly from a gINT project into Excel using this
method.
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Summary

As you can see, there are many ways to work with Excel data in gINT, or to export gINT data to Excel
and work with it there. gINT has an expansive ability to manipulate and format data within its own
features and applications, but should you need or desire to work with an external application such as
Microsoft Excel, gINT has the tools to do so.
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