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Overview of GEO5-gINT Integration Options

You export data from gINT to GEO5 in INPUT using the File P> GEO5 Export menu. There are three
GEO5 export options:

Terrain Data: This creates a .gil file, which exports the points of a surface for use in the GEO5
Terrain module. It obtains the ground surface elevations, or the top or bottom of a particular
lithology layer, for each point. See “Terrain Data” on page 21.

Profile and Soil Data: This creates a .gi2 file, which exports layering and soil properties
information. This exported gINT data is used by all of the design and analysis modules in GEO5
(with one exception: the Terrain module only uses the soil properties). Layering information is
exported from the LITHOLOGY table or equivalent, and soil properties information comes from
a GEOS5 SOILS table that you create. See “Profile and Soil Data” on page 4.

CPT Data for Pile Design: This creates a .gi3 file, which exports borehole elevation and CPT
sounding data for use in the GEO5 Pile CPT module. It uses the Depth and Elevation fields from
the POINT table, and depth and tip resistance fields from a CPT table in your database. See
“Pile Design CPT Data” on page 16.

Exporting from gINT to GEO5 requires:

gINT version 8.2.003 or later

GEOS5 version 5.8 or later

Obtaining the Demo Application

A sample gINT-to-GEO5 export application is provided on the gINT Software website. It provides
projects, correspondence files and a library that illustrate gINT-to-GEO5 export capabilities. These files
can be used to demonstrate the various export setup processes. Also, you can transfer some of the
table structures and data to your own projects and library, saving data entry time. This is described
later in the text.

To obtain the sample application, do the following:

1.

Go to www.gintsoftware.com/support doc.html.

1
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3.
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Click on the link ‘Data Files for GEO5 Integration User Guide only’. The zip file you download
contains the following files:

Type Files

Projects geob profile-soil export.gpj
geo5 cpt export.gpj
geo5 terrain export.gpj

Correspondence Files | geo5 profile-soil.gcx
geo5 cpt pile design.gex

Correspondence geob5 profile-soil template.csv

Target Files geo5 cpt pile design template.csv
(templates)

Library geo5 export.glb

Extract to the following locations:
o The project files to your \projects\ folder
o The correspondence files and correspondence target files to your \datatmpl\ folder

o The library to your \libraries\ folder

& Note: We suggest you use the UTILITIES P> Extract From Zip option to extract the files quickly to
these locations.

Running the Demo Application

To see how export to GEO5 works for profile and soil data, do the following:

1.
2.

Download and extract the sample application, as described in the previous section.

In gINT, go to INPUT. Change libraries to ‘geo5 export.glb’ and open the ‘geo5 profile-soil
export.gpj’ project.

Select File P GEO5 Export P Export GEOS5 Profile and Soil Data.

In the GEO5 PROFILE AND SOIL DATA dialog box, click the Browse === button to the right of
GEOS File. Browse to any folder and enter a filename of ‘test soil-profile export.gi2’ and click
Save.

Click the Browse button to the right of Correspondence File. Select ‘geo5 profile-soil.gcx’
then click Open. Correspondence files are described in “Creating and Modifying the
Correspondence File” on page 11.

Click OK. The .gi2 file is generated and a status log is displayed. Click OK to close the status
log.

2
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Open “test soil-profile export.gi2’ with a text editor. This is a text file with the data arranged
according to a preset format.

I test soil-profile export.gi2 - Notepad E|@|Pg|
File Edit Formab Wiew Help

*HEADER -~
VERSION, CHARSET
1,0

WHEQILS

MAME , HATCHMAME , HATCHCOLOR , BASTC_GAMA, BASIC_EFF_PHI, BASIC_EFF_C, NY
,OCR, ECED, EDEF

20, pcf, deg, pst, , , psf, psf

Eedrock 1,sAMNDSTOME,&5535,125,20,9000,,,,
Eedrock 2,SILTSToME,255,122,17,8000,,,,

Clayey sand 1,CLAYEY_SAMD,65535,115,25,200,,,,
Clayey sand 2,CLAYEY_SAND,65535,112,29,250,,,,
sand, SAND,65535,116,28,0,,,,

sandy Clay, SaMDY_CLAY, 32896,110,15,1200,,,,
surface Gravel,GRAVEL,16711680,120,30,300,,,,

HYPROFILE

EOREHOLE, TCPDERTH, BOTTOMDERTH, SOIL
,ft,ft,

B-1,0,5,surface cravel
-1,5,10,CTayey Sand 1

10,13, sandy CTay

13,21, sand
21,25, CTayey Sand 2
25,44.5,Bedrock 1
44,5, 50, Bedrock 2
0,3,surface cravel
3,12, Clayey sand 1
12,28, 5and
28,40,Bedrock 1
0,8,surface Gravel

3,8,Clayey sand 1

9,15, sandy Clay

15,26, 5and

26,42, Bedrock 1

42,45, edrock 2

0,2,surface Gravel w

OmmommmMmIDmmomommoommm

-1
-1
-1
-1
-1
=
=5
=
=
-3
-3
-3
-3
-3
-3
-4

Close the text editor.
Open the Slope Stability module in GEO5.
In GEO5, select File > Import P Format GI2 (gINT soils and profiles).

Import gINT (soils and profile) r§|

File GIZ

File name : |

Import parameters

r

= [

r

[ Ok | [ Cancel ‘

Click the Open button and browse to the .gi2 file you previously exported.
In the Selected Profile dropdown, select borehole B-1. Click OK.
Click the Soils tab in the Modes list at right.

The lithology layers for borehole B-1 appear in GEO5 Slope Stability, with the soil types listed
in the lower half.

3
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#3 Geo 5 - Slope stability [Untitled.gst*]
File Edit Input Pictures 3Settings Help

s fo=2 = By Bs @ Q¢ OoOQ #

Construction stage : [ [1]

-2400 200 -18.00 -15.00 -12.00 -8.00 -E.00 300 0on 200 E.00 5.00 1200 15.IIJU .

|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|I|||I13-[n.1]. Modes =

2 Project

et Interface

£ Soils
A Rigid bodies
5 Assign

List of soils About soil characteristi
OEIE Soil name Bedrock 1 ~ NN & ndd < 'qnf:h':'rs
> 1 |Bedrock 1 Uit weight : . =] Reinforcements

> |Bedrock 2 Angle of internal Friction Modify P Surcharge

SR gzrui?:f:;?':{eight ; | 5 pemove | | = Water

4 |Clayey Sand 2 N -

5 |5and ' P|ctures—_

6 |Sandy Clay Add picture

7 |5urface Gravel T e — 0
Total ]

Lisk of pictures

Soils

15. Close GEOS. Click No when you are prompted to save.

Profile and Soil Data

Setting up your project databases and related files for GEO5 profile/soil data export includes the
following steps:

e Copying the hatch patterns library table from the demo application
e Copying the GEO5 SOILS database table from the demo application
e  Configuring the units in GEO5 SOILS

e Performing GEO5 SOILS data entry

e Adding a field to your lithology layers table

e Replacing your standard data template with the modified database structure, and applying this
to projects

e Creating the correspondence file

After this set of steps has been performed once, you can perform regular exports of layer and soil data
from gINT projects to GEO5. The steps are described in detail in the subsections that follow.

4
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Setting up gINT Tables in your Project and Library

You need appropriate tables and fields in your gINT database before you can export to .gi2 format:

A library table of hatch pattern names: This needs to be in your library with all the valid
GEOS5 hatch names. You can copy this from the library in the demo application.

A database table with soils data: You will need to create this in your project. You can copy it
from the project in the demo application.

A database table of lithology layers, such as LITHOLOGY (in standard gINT projects) or STRATA
MAIN (in AGS compatible projects). This table probably exists, but you will need to add one
field and perform data entry into it.

Hatch Patterns (Library Table)

There are forty hatch pattern names currently accepted in GEO5 applications. In your soils table (which
we create shortly), you need to assign one of these to each soil you use. Rather than manually entering
the hatch pattern name for each soil, which is slow and prone to mistakes, you create the list of hatch
patterns as a library table. This library table can be used as a lookup in the Hatch Name field for each

soil.

Since this library table already exists in the demo application’s library, you can copy it to your library
using Lib Merge/Copy. Do the following:

1.

a A W DN

If you have not installed the demo application files, do this first. Instructions are in “Obtaining
the Demo Application” on page 1.

Open your library (the library you normally use).
Go to UTILITIES P> Lib Merge/Copy.
Select the Merge From radio button.

Click the Browse button to the right of Source Library File. Browse to the ‘geo5 export.glb’
file and click Open.

Highlight ‘GEO5 HATCHES’ in the Available Source Tables list, then click the Move Item Right
ﬂ icon. Click Execute.

In the GEO5 HATCHES dialog box, click the Move All Items Right ﬂ icon then click OK.
Click OK to dismiss the Merge/Copy Completed message box.

5
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9. Go to DATA DESIGN P> Library Data and select ‘GEO5 HATCHES’ in the object selector. The
lookup list appears:

GED5 Hatch Hatch Mame
BRECCIA Breccia

CLAY Clay
CLAYEY_GRAVEL Clayey Gravel
CLAYEY_SAND Clayey Sand
CLAYSTOMNE Clayztone
COARSE_GRAINED_FILL Coarze Grained Fill

'CROS55_HATCH_DASHED_LINES_45_135 |Cross hatch dashed lines at 45° and 135°

CROS55_HATCH_SOLID_LINES_30_120 Crozs hatch solid lines at 30° and 120°
CROSS_HATCH_SOLID_LINES_60_150 Crogs hatch solid lines at 60° and 150°

DISCONTINUITY_FILLINGS Discontinuity Fillings
FILL Fill
FINE_GRAINED_FILL Fine Grained Fill
GABRD Gabro

GRANITE Granite

Notice that the Hatch Name field makes it possible for you to translate the names into another
language, if your country is non-English-speaking. However, you should not change the values
in the GEO5 Hatch field, since these values need to be passed as written to GEOS.

Soils Data (Database Table)

You will need to set up a table in your gINT project to store your soil definitions. This will act as a
lookup in associating a soil to a layer. It also assigns a set of properties to each soil that you will need
in GEOS5.

You can manually create the table and all the fields in DATA DESIGN, but since this already exists in
the demo application, it’s faster to copy it from there. Do the following:

1. Go to DATA DESIGN P> Project Database.

2. Open the project that you will be exporting to GEO5.

3. Select Tables P Import Table. In the CHOOSE A DATABASE file browser, select ‘geo5 profile-
soil export.gpj’ from the demo application then click Open. The table selection dialog box
appears:

2= select table from ‘pend profile-soil export.gpj

Source table |[FEIEEIIE |

Mew name [optional] | |

(1] | Cancel ‘ Help | Reszet |

4. Select “GEO5 SOILS’ in the Source Table dropdown then click OK.

6
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5. Go to INPUT. There is now a Geo5 Soils tab. Click this tab. The data entry grid for the GEO5
SOILS table appears:

INPUT | OUTPUT | DATA DESIGM | REPORT DESIGN | SYMBOL DESIGN | DRAWINGS | UTILITIES

Main Group

Project | Borehole | Lithology | Sample | waterlevels | well Gend Sails _
Table Help
>
Soil Hame Hatch Hame Hatch Color Unit  Effective Effective Poizzons Over Oedometric Deforma
| Weight | Friction = Cohesion Ratio Consolidation Modulus tion
[pch) Angle

[p=f] Ratio [p=f] Modulus
| | lpsh) |

[deg)

6. Click in the Hatch Name field. Notice that there is a lookup that includes all the hatch names
in the GEO5 HATCHES library table. Press Esc.

Setting up the Units

The units have to be defined for each field that is expressed in specific units. To do this, right-click the
cell under each of the following fields, select Field Properties, and select the appropriate Units
property value for your data. The following table shows acceptable Units values for the indicated
fields. If you need a unit that is not available in the Units property value in Field Properties, add it
first in the ‘Field Units’ library table in DATA DESIGN P> Library Data.

Field Units

Unit Weight In the imported table the units are ‘pcf’, but you can change this to any of
the following:

e KkN/m3: KiloNewtons per cubic meter

e N/ft3: Newtons per cubic meter

o kcf: Kips per cubic foot

e kci: Kips per cubic inch

e pcf: Pounds per cubic foot

e pci: Pounds per cubic inch

Effective Friction Angle In the imported table the units are ‘deg’, but you can change this to any of
the following:

deg: degrees

rad: radians

mrad: milliradians

grad: 1/400th of a full circle. Also known as "gon",
"gradian”. 100 grads = 90 degrees.

grade", and

Effective Cohesion In the imported table the units are ‘psf’, but you can change this to any of
the following:

e Pa: Pascals

e kPa: Kilo Pascals

e MPa: Mega Pascals

o  ksf: Kips per square foot

e psf: Pounds per square foot

e  ksi: Kips per square inch

e psi: Pounds per square inch

Oedometric Modulus

Deformation Modulus

7
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%~ Note: The units listed here are the units that are accepted by GEO5. You can set up any units you
want in INPUT, then perform a conversion on export to units that GEO5 accepts. This is configured
in the correspondence file. See “Calculated Expressions for Units Conversion” on page 13.

Data Entry

To populate the SOILS GEO5 table, you will need to review your field and laboratory results to obtain a
reasonable value for each of the properties that will be used. Here are explanations of these fields:

Soil Name: Enter an arbitrary name for the soil. This name will be assigned to particular
lithology layers. A soil can be assigned to multiple layers. Note that this name must be unique
within the SOILS GEOS5 table.

Hatch Name: This field specifies the GEO5 hatch pattern that will be associated with the soil
type. GEO5 will use this hatch pattern when drawing any layer that uses this soil.

Hatch Color: This specifies the color that will be used in displaying or printing the hatch
pattern. Select this from the dropdown list.

Unit Weight: The total unit weight of the soil. This will translate into the BASIC_GAMMA field
in GEO5.

Effective Friction Angle: The effective friction angle of the soil. This will translate into
BASIC_EFF_PHI in GEOS5.

Effective Cohesion: The effective cohesion of the soil. This will translate into BASIC_EFF _C in
GEOS.

Poissons Ratio: This will translate into NY in GEO5. This field is unitless.
Over Consolidation Ratio: This will translate into OCR in GEO5. This field is unitless.

Oedometric Modulus: This will translate into EOED in GEO5. Search for "Oedometric Modulus"
in GEO5 Help while in the Settlement module for details.

Deformation Modulus: This will translate into EDEF in GEO5. Search for "Deformation Modulus"
in GEO5 Help while in the Settlement module for details.

@ Note: It is not necessary to enter values in all fields for each soil type. You only need to provide
the soil properties for the items that will be needed in the specific analyses that you will be
carrying out in GEO5. For example, if you are performing settlement analysis, you must provide the
Over Consolidation Ratio and either the Oedometric Modulus or Deformation Modulus, but
Effective Friction Angle and Effective Cohesion are not used. If you are analyzing a cantilever
wall, Over Consolidation Ratio, Oedometric Modulus, and Deformation Modulus are not used.

Lithology Data (Database Table)

Your database should already have a table that identifies lithology layers. In many standard gINT
databases this is LITHOLOGY. In AGS databases it is STRATA MAIN. For export to GEO5, your lithology
layers database needs to have fields with the following data:

Borehole number: This is the PointID field.

Top depth: This is the Depth field.

8
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e Bottom depth: This is the Bottom field in some databases. Alternately you may have a Length
field that is added to Depth to obtain the bottom depth value. Either of these table designs is
acceptable.

e Soil: You have to add a field to your table for this. We will call it GEO5 Soil. This field will let
you associate the lithology layer with a soil type record in GEO5 SOILS. This is necessary for all
the layer rows you are exporting to GEO5.

Note that units need to be specified for the top depth and bottom depth fields. You can verify this by
looking for the units in parentheses in the column headings in INPUT, as shown. If not present, specify
the units by highlighting a cell in each of these columns then choosing Table P Field Properties or
right-click P> Field Properties then selecting a value for Units.

Bottom USCS Graphic

(ft)
MEW-EE

GEOS5 Soil Field
To create and configure the GEO5 Soil field in the lithology table, do the following:

1. InINPUT, select the lithology table (generally the Lithology tab).
2. Select Tables > Add Field.

3. In the Field Properties dialog box, enter the following values:

Property Value Notes
Name GEO5 Sail
Type Text
Lookup PRJTBL!ge05 soils To specify the lookup:
1. Click the Browse button to the right of
Lookup.
2. In the Type dropdown, select ‘PRJTBL’.
3. In the Name dropdown, select ‘GEO5 SOILS’.
Must Use Lookup | checked

4. Click OK to close Field Properties and save the new field in the database structure.

5. Click in the GEO5 Soil field for one of the lithology records. Notice that a dropdown list
appears. Click on the dropdown arrow. If you have entered data in the SOILS DATA table, the
Soil Name values in records there will appear in the dropdown list.

6. Press Esc to close the dropdown.

Modifying and Using your Standard Data Template

The table and field properties for the new GEO5 SOILS table, and field properties for the GEO5 Soils
field in the lithology table, should be saved to your data template. Then this template can be used to
replicate these changes in other project databases. There are utilities you can use to accomplish this.

9
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Saving Changes to the Data Template
1. Select Tools P Make Data Template.

2. Specify the location and name of the data template to create. Click Save.

Convert Databases

This project conversion method converts many database files at once, but also deletes all tables and
fields that aren’t in the data template. If this limitation is not a problem, this is the fastest conversion
technique for multiple files.

% Note: Initially you should test this on one project, after making a backup copy of the project.
To use this method, do the following:

1. Go to UTILITIES P Convert Projects.
2. Click the Browse === button to the right of Data Template. Select the data template you just
created, and click Open.

3. Click the Browse button to the right of Convert Files. Select as many project files as you want
to convert, using Shift-clicking and/or Ctrl-clicking. Click Open.

Click the Execute button. The specified project files are converted, if possible.
View the status log. This indicates success or problems with the conversion.
Click OK to close the status log.

In INPUT, open the project that was converted. Verify that the changes are what you wanted.

o N o o1 b~

Repeat the process for a larger group of projects.

Merge All Tables and Fields

If Convert Databases is too destructive, an alternative is the Merge All Tables and Fields option in the
Tables menu in INPUT or DATA DESIGN. This method has to be performed on each project one at a
time. However, the benefit is that it does not delete any tables or fields in the database that differ
from the template. To use this method, do the following:

1. Go to INPUT or DATA DESIGN P> Project Database. Open the project you want to convert.
2. Select Tables P Merge All Tables and Fields.

3. In the CHOOSE A DATABASE dialog box, select the master data template from the \datatmpl\
folder and click Open.

4. Notice in the object selector that there is now a GEO5 SOILS table in your project. Also, if you
select the LITHOLOGY table in the object selector, notice that there is a GEO5 Soil field in the
table.

The tables and data entry grids in the converted project are now correctly configured for GEO5
soil and profile export.

5. Replace your existing data template (Tools P Make Data Template).

0
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Creating and Modifying the Correspondence File

You need an appropriately configured correspondence file to convert a project’s lithology and soil data
to .gi2 format. Once this correspondence file is created, you can use it to convert any project that has
been structured as described in the previous section.

We will create a correspondence file from scratch. However, if you are already familiar with
correspondence files and your project is similar to the demo project, you can modify the example
correspondence file that was provided in the demo application. To create the correspondence file, do
the following:

1. Go to DATA DESIGN P Correspondence Files.

2. Select File P> Open. Select ‘geo5 profile-soil.gcx” in the OPEN CORRESPONDENCE FILE dialog
box, and click Open.

The file looks like this in the Correspondence Files tab:

E= DATA DESIGN - Correspondence Files: c:\program files\gintidatatmpligeo5igint to geo5 profile-soil-gcx Libra... g@g|
Eile Edit Help

=} JoN= B

INPUT OUTPUT DATA DESIGH l REPORT DESIGH I SYMBOL DESIGH ] DRAWINGS UTILITIES ]
Project Database | Library Tables | Library Data | Lookup Lists | Readings Lists | User System Data  Comespondence Files

Target File Browse for Folder [ Source File Browse for Folder [
Target Table Refresh Fields
[s0ILS ~] aAnFs) | Cument | Add Group |

Write Structure to File

r;?;;g;::me Table j Table Field Paste Sysler{w Itemns Paste
|GEO5HATCHES - | [GEOS Hatch | [Furctions | [245HTO_Group_ind ~|
Set Empty Sources to <<0mit>>
Target Field Source Expression S
NAME <<GEDS S0ILS Itemkey>>
HATCHHAME <<GEDS 50ILS Hatch Hame> >
HATCHCOLOR <<GEDS S50ILS Hatch Color>>
BASIC_GAMA <<GEDS S0ILS Unit Weight>>
BASIC_EFF_PHI <<GEDS S0ILS _Effective Friction Angle>>
BASIC_EFF_C <<GEDS S0ILS Effective Cohesion>»
NY <<GEODS SOILS Poissons Ratio>>
OCR <<GEDS SOILS Dver Consolidation R atio>>
EOED <<GEDS5 SOILS Dedometric Modulus>> bt
Raw 1
of 10

Creation and editing of a correspondence file takes place here.

3. Select File » New File. This clears the settings.

4. Click the Browse == button to the right of Target File. Select ‘Text Files’ in the Files of Type
dropdown, and open ‘geo5 profile-soil template.csv’.

1
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Data appears in the tab.

Project Database | Library Tables | Library Data | Lookup Lists | Readings Lists | User System Data  Comespondence Files

SOIL

Click the Target Table dropdown. Notice that two table names appear: SOILS and PROFILE.
These are the table names that GEO5 expects on import.

Select SOILS in the Target Table dropdown. Notice that a different list of fieldnames appears
in the gray Target Field column in the data entry grid.

The Target Field column lists the fields that GEO5 expects in the incoming PROFILE or SOILS
table. When the Target Table is ‘SOILS’, the list of SOILS fields appears, and similarly for
‘PROFILE’.

We have identified the names of the output (GEO5) tables and fields (thanks to the template
file we opened). Now we need to identify the names of the input (gINT) tables and fields.
Click the Browse === button to the right of Source File. Select ‘gINT’ in the Files of Type
dropdown, navigate to your \datatmpl folder, and open the data template you created.
Ensure that “‘SOILS’ is selected in the Target Table field.

In the Default Source Table dropdown, select ‘GEO5 SOILS’.

In the Table dropdown in the Data Tool (the set of four dropdowns with Paste buttons) select
‘GEO5 SOILS’.

Enter each of the following values by 1) clicking in the Source Expression cell to the right of a
corresponding Target Field, 2) selecting the source field from the Field dropdown in the Data
Tool, 3) clicking the Paste button above the Field dropdown, and 4) pressing the Tab key:

Target Field Source Field
NAME <<GEO5 SOILS.ItemKey>>
HATCHNAME <<GEOS5 SOILS.Hatch Name>>
HATCHCOLOR <<GEO5 SOILS.Hatch Color>>
BASIC_GAMA <<GEO5 SOILS.Unit Weight>>
BASIC_EFF_PHI <<GEO5 SOILS.Effective Friction Angle>>
BASIC_EFF C <<GEOS5 SOILS.Effective Cohesion>>

2
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Target File Browse for Folder | Source File Browse for Folder |
[C:\...\geo5 profile-soil template.csv | | | | ...
Target Table Refresh Fields
FROFILE *| Al[F3] | Cumrent Add Group
J | | | Write Structure to File
‘ Target | ‘
Default S5ource Table :
| ﬂ Table Field Paste Spstem Ibems Paste
|GEOSHATCHES | [GEOS Hatch | [Functions | |AA5HTO Group_Ind = |
Set Empty Sources to <<0O0mit>> ‘
Target Field Source Expression
BOREHOLE
TOPDEFTH
BOTTOMDEPTH
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Target Field Source Field
NY <<GEO5 SOILS.Poissons Ratio>>
OCR <<GEO5 SOILS.Over Consolidation Ratio>>
EOED <<GEO5 SOILS.Oedometric Modulus>>
EDEF <<GEO5 SOILS.Deformation Modulus>>

12. Change the Target Table to ‘PROFILE’.

13. Change the Default Source Table and Table dropdowns to ‘LITHOLOGY” (or whatever the name
is of your lithology layers table).

14. Enter the following values in the grid. This assumes that you are using a standard gINT
database, with a LITHOLOGY table and typical field names. Otherwise, use the appropriate
field names in your database.

Target Field Source Field

BOREHOLE <<LITHOLOGY.PointID>>

TOPDEPTH <<LITHOLOGY.Depth>>

BOTTOMDEPTH <<LITHOLOGY.Bottom>>

SOIL <<LITHOLOGY.GEO5 Soil>>

15. Select File P> Save As, save to ‘geo5 profile-soil.gcx” in \datatmpl\ (this overwrites the
original).
a For more complete information on creating and modifying correspondence files, see the

“Correspondence Files” chapter in the Using Data Design tutorial. Alternately, go to Help »
Index P> Correspondence Files.

% Note: The correspondence file is designed to create the “**SOILS” and “**PROFILE’ sections of the
.gi2 file. This will work even if you use File » Import/Export B Export to Text File rather than
File » GEO5 Export. However, GEO5 also expects a short “**HEADER’ section at the beginning of a
.gi2 file, which the GEO5 Export option will create and the Export to Text File option will not.

Calculated Expressions for Units Conversion

The units exported to the .gi2 file for each field are obtained from the Units setting in the field
definitions, as described in “Setting up the Units” on page 7. However, the units in your gINT database
table may differ from the units you want exported to GEO5, possibly because your units are not
supported in GEO5. This conversion can be performed in the correspondence file.

For example, we defined the conversion for the Unit Weight field in GEO5 soils, which converts to a
field in GEO5 called BASIC_GAMA, as follows:

T arget Field Source Expression
HAME <<GED5 SOILS ItemKey>>
HATCHNAME | <<GED5 SOILS.Hatch Name>>
HATCHCOLOR ' <<GED5 SOILS Hatch Color>>
BASIC_GAMA | <<GED5 SOILS . Unit Weighty> <f——
13
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As written, the Source Expression for this field performs no units conversion. However, if your unit
weights are in Mg/m3 in the table, and you want to export them to kN/m3, you would need an
expression like this:

<<Calc(<<GEO5 SOILS.Unit Weight>> * 9.807)>>

This will export the correct converted value. However, the stated units for BASIC_GAMA in the header
of the “**SOILS” section will still be the Units setting for the Unit Weight field in the GEO5 SOILS table,
namely ‘Mg/m3’. This will cause the exported data to be incorrectly interpreted in GEO5. To force the
output file to use different units than what is in the Units setting for the field, you include a
FieldUnits() expression next to the Calc() expression. The argument for the FieldUnits() function is
‘kN/m3’ in this case, as shown:

<<FieldUnits(kN/m3)>>
The complete Source Expression value for BASIC_GAMA would thus be the following:

<<FieldUnits(kN/m3)>><<Calc(<<GEO5 SOILS.Unit Weight>> * 9.807)>>

Exporting the .gi2 File

After you have completed the steps in the previous sections you can generate a .gi2 file for export to
GEO5. Do the following:

1. Go to INPUT. Ensure that the project you want to export is open.

2. Select File > GEO5 Export P Export GEO5 Profile and Soil Data. The following dialog box
appears:

2= EXPORT GEOS5 PROFILE AND SOIL DATA

GEOS File | | ...
Comespondence File | | |

Select Points | | |

oK | Cancel Help | Beszet |

3. Click the Browse === button to the right of the GEO5 File property. In the file browser dialog,
select an output folder, enter a filename for the .gi2 file, and click Save.

4. Click the Browse button to the right of the Correspondence File property and specify the .gcx
file you previously created. Click Open.

5. If you only want to export data for some of the points in the project, click the Browse button
to the right of Select Points, choose the desired points, and click OK. Otherwise, leave the
Select Points property blank, and all points are exported.

Click OK. A status log window appears.
Verify that the export was successful according to the log then click OK.

Open any GEO5 module (whichever one you want to import the data into).

© 00 N o

Select File P> Import P Format GI2 (gINT soils and profile)

4
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10. Click the Open button and browse to the .gi2 file you previously exported.

11. In the Select Profile dropdown, select the desired borehole. Click OK. The profile and soils
data for the borehole is imported from the .gi2 file.

5
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Pile Design CPT Data

Setting up your project databases and related files for GEO5 CPT data export includes the following
steps:

e Ensuring that the proper fields are present in POINT and your CPT table and that units are
specified

e Creating the correspondence file

Once this set of steps has been performed once, you can perform regular exports of CPT data from
gINT projects to GEO5. The steps are described in detail in the subsections that follow.

Configuring the Database Tables

The following tables need to be correctly configured for CPT data export:

e POINT table: Make sure that the Depth and Elevation fields have units and Elevation is
Required.

e CPT table: Make sure that the table is a child of POINT, that there is a depth and a resistance
value for each sounding, that these have units specified.

POINT Table

The Elevation field is present in all gINT project databases, so it does not need to be added. However,
you need to set the Units property for the field in INPUT P Tables P> Field Properties or DATA DESIGN
P Project Database to one of the following:

e mm: millimeters
e cm: centimeters
e dm: decimeters
e m: meters

e in: inches

ft: feet

16
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CPT Table

You need to have a table containing CPT data in your database. It must be a child of POINT, and needs
to contain the following numeric fields (not necessarily with the names shown):

Field Description Allowable Units

Depth Depth of the sounding, in distance units. | mm: millimeters
cm: centimeters
dm: decimeters
m: meters

in: inches

ft: feet

Resistance Resistance reading from the sounding, in | Pa: Pascals

pressure units. kPa: Kilo Pascals

MPa: Mega Pascals

ksf: Kips per square foot
psf: Pounds per square foot
ksi: Kips per square inch
psi: Pounds per square inch

To specify the units for each of these fields, set the Units property in INPUT P Tables P Field
Properties or DATA DESIGN P> Project Database.

Updating your Data Template

You need to export the above project structure changes to your standard data template. To do so,
choose Tools P Make Data Template in INPUT. Then these changes should be propagated to your
projects using one of the techniques described in “Modifying and Using your Standard Data Template”
on page 9.

Creating the Correspondence File

You need a correspondence file to convert CPT (and parent POINT) data to .gi3 format. Once this
correspondence file is created, you can use it to convert any project that has been structured as
described in the previous section.

We will create the correspondence file from scratch.

1. Go to DATA DESIGN P Correspondence Files.

2. Select File » New File.

3. Click the Browse === button to the right of Target File. Specify a Files of Type of ‘Text File’
and select ‘geo5 cpt pile design template.csv’ from “\gINT\datatmpl\’. Click Open.

4. Click the Browse button to the right of Source File. Specify a Files of Type of ‘gINT” and open
the ‘geo5 cpt export.gpj’ project.

5. Select a Target Table of ‘CPTLIST’.

7
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6. Select ‘POINT’ in the Default Source Table dropdown and the Table dropdown in the Data
Tool.

7. Enter each of the following values by 1) clicking in the Source Expression cell to the right of a
corresponding Target Field, 2) selecting the source field from the Field dropdown in the Data
Tool, 3) clicking the Paste button above the Field dropdown, and 4) pressing the Tab key:

Target Field Source Field
NAME (see “Conditional Export of POINT Records” below)
ELEVATION <<POINT.Elevation>>

8. Select ‘CPT’ in the Target Table dropdown.

9. Select the name of your CPT table in the Default Source Table dropdown and the Table
dropdown in the Data Tool.

10. Enter each of the following values (as above):

Target Field Source Field
NAME <<CPT.PointID>>
DEPTH <<CPT.Depth>>
RESISTANCE (see “Data Conversion and Conditional Export of CPT
Records” below)

11. Select File P> Save As, and save to ‘gint to geo5 cpt pile design.gcx’ in \gINT\datatmpl\ (this
overwrites the original).

Conditional Export of POINT Records

You will need to eliminate the export of points that have no CPT soundings. There may be POINT
records that have no child records in the CPT table. In gINT this is allowed, but a .gi3 file with childless
CPT records will be rejected by GEO5.

Suppression of childless points can be accomplished in the NAME field in the POINT section of the
correspondence file using the <<ExportKey>> data item. <<ExportKey>> will suppress the output of a
record if a field or calculated expression on the same row of the correspondence file returns a null
value. Therefore, we use the <<ExportKey>> data item followed by the following IIf (immediate If)
expression:

<<l I'F(<<Count(<<CPT.Tip Resistance>>)>> > 0,<<POINT.PointlID>>)>>

This expression counts the number of CPT records with a non-empty Tip Resistance field. If the count
is greater than zero, there is at least one non-empty CPT record for the current point. The IIf()
function will return the PointID of the POINT record; otherwise it will return a null value.

By combining the above IIf() expression with <<ExportKey>>, a null IIf() return value will suppress
output of the point’s record. Thus we enter the following in the Source Expression for the NAME target
field in target table CPTLIST:

<<ExportKey>><<IIT(<<Count(<<CPT.Tip Resistance>>)>> > 0,<<POINT.PointiD>>)>>

8
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0 For more information on the <<ExportKey>> data item, see Help P> Index P ExportKey (data
item).
Data Conversion and Conditional Export of CPT Records

Some CPT tip resistance units, such as tsf, are not supported in GEO5. In this case you need to convert
the value to the appropriate number as well as change the units setting using FieldUnits(). For
example, a change from tsf to ksf would require the following expression:

<<FieldUnits(ksf)>><<Calc(<<CPT.Tip Resistance>> * 2)>>

Also, gINT should be prevented from exporting CPT records with null tip resistance values, as this
would cause GEOS5 to reject the import file. Hence, you would use <<ExportKey>> with the tip field if it
requires no conversion:

<<ExportKey>><<CPT.Tip Resistance>>
or with FieldUnits() and a conversion expression:

<<ExportKey>><<FieldUnits(ksf)>><<Calc(<<CPT.Tip Resistance>> * 2)>>

Exporting the gi3 File

Using the previously created correspondence file you can generate a .gi3 file for export to GEO5 CPT
Pile Design. Do the following:

1. Go to INPUT. Ensure that the project you want to export is open.

2. Select File P GEOS5 Export P> Export GEO5 CPT Data for Pile Design.

3. Click the Browse **= button to the right of the GEO5 File property. In the file browser dialog,
select an output folder, enter a filename for the .gi3 file, and click Save.

4. Click the Browse button to the right of the Correspondence File property and specify the .gcx
file you previously created. Click Open.

5. If you only want to export data for some of the points in the project, click the Browse button
to the right of Select Points, choose the desired points, and click OK. Otherwise, leave the
Select Points property blank, and all points are exported.

Click OK. A status log window appears.
Verify that the export was successful according to the log then click OK.

Open the GEOS5 Piles CPT module.

© 0 N O

Click the Experiments tab in the vertical tab bar at right.

10. Click the Import button at bottom right.

11. In the Import CPT dialog box select ‘Format gINT’ in the Type of File dropdown.
12. Click the Add button. Select the .gi3 file you just exported and click Open.

13. Click Import. Your imported points are listed in the table at the bottom of the GEO5 - Piles
CPT window.
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14. To view the imported CPT soundings for one of the CPT points, double-click on the point’s row
in the table. A dialog box for viewing and editing the soundings data appears.

Marne

Depth of 1st CPT paint from arig. terrain: h= [m]
Imported elevation of 1st CPT point = 37,63 m.

L] |Ej | ] Depth Resitance ) add
Seq. Mo, Z [m] q. [MPa]
s 1 0.00 o.00| ™ Edit
z 011 0.0
& 0.1z 0.0z |
4 0.14 0.02
5] 0.15 0.0z
& 0.17 0.02
7 0.1s8 0.0z
g 0.20 0.02
9 0.21 0.01
10 0.23 0.
11 0.24 0.01 -
12 0.26 0.0 a0z
13 0.27 0.01] [MPa]
| | [ Change parameters of standard profile
,7

‘ [ oK ‘ X Cancel
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The Terrain module in GEO5 can use imported gINT data that models surfaces. Typically the kinds of

surfaces you will export from gINT are the ground surface and the depths of particular lithology layers.
Each surface must be exported to a separate .gil file. Note that unlike the other gINT-to-GEO5 exports,
export of surface/terrain data does not use a correspondence file.

We will show a simple export process for two surfaces then briefly discuss more complex surface export
scenarios.

Exporting Ground and Top of Bedrock Surfaces

We will show the export of two surfaces, ground surface and top of bedrock. Both use standard
features in the interface, and require no customization.

1.
2.

In INPUT, open the “‘geo5 terrain export.gpj’ project.

Select File » GEOS5 Export » Export GEO5 Terrain Surface Data. You see the EXPORT GEO5
TERRAIN SURFACE DATA dialog box:

2= EXPORT GEO5 TERRAIN SURFACE DATA

Main | Depth Table Filter |

Export to File (8 EGTTET NSRS

specify a the file name and
location, then click Save.

Field containing Z
values

[POINT].[Elevation]

Z Values are

Elevation

The program assumes that the X and Y values are the native North and East coordinates in the
project database. The Field Containing Bearing field is only applicable if you have inclined
holes. However, inclination of the hole has no effect on the Z values on a ground surface.

If you want to export only specific boreholes, click the Browse El button on the Select Points
field to select the boreholes you want to export. Otherwise, leave the field blank to export all

points.

1
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Z Yalues are |Elevation =]
Field containing Bearing [for inclined holez] |Mone -
Select Points | . |
1] 4 | LCancel | Help | RBeset |
Enter the following values in the Main tab:
Field Name Value Comments
Export to File ground surface.gil Click the Browse button and
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5. Click the Depth Table Filter tab. Specify ‘None’ for the Filter Field.

6. Click OK. A status log tells you how many records were exported. Click OK to dismiss the status

log.

7. To see the structure of the data being exported:

a
b.

(@]

Open ground surface.gil in Excel
Highlight the first column

Select Data P> Text to Columns

Select Delimited, then check the Comma delimiter checkbox, then click Finish. A sample
appears below:

B3 Microsoft Excel - ground surface.gil

i2] Ele Edt  Vew Insert Format Tools Data  Window Help  Adabe POF Type 3 question for help =12 @ X
HRN=A" NERENE= RN A N RN A RARAE- N LN © FELY .
ol - HEEl
p22 - f

A | B [ ¢ | o [ E | F [ & [ H [ 1+ [ J [ K [ F
1 ["HEADER
2 |WERSION CHARSET
3 1 a
4
5 |TPOINTS
B (D A ' z
7 ft ft ft
8 |B- 1 5627 1434.5 40
9B 2 BE0.6 145248 34
10 |B- 3 7897 1457 .5 30
11|B- 4 875.5 1454 6 25
12 |B- & 956 14546 20
15 |B- B 1019.8 14731 15
14168 7 11205 1463 10
15 |B- & 12196 14747 15
16 |B- 9 1431 14697 20
17 |B- 10 15683.58 1476.4 25
18 |B- 11 1860.7 14445 30
19 |B- 12 556.6 12545 35
20 [B-13 E79.1 1233 30
21 |B-14 ahg.3 1065 30
22 [B-15 526.3 8787 25
S = = EAE A TAT n| :! b
M 4 » M} ground surface / |< >
Ready

8. Notice that the first column in the “**POINTS’ section holds PointID values, and the three
columns that follow (X, Y and Z) hold East, North and Elevation values.

9. Close Excel, and do not save the changes.

We will export another gil file, this time for top of bedrock values.

1. Select File » GEO5 Export » Export GEO5 Terrain Surface Data.

2
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2. Select the following values in the Main tab of the EXPORT GEO5 TERRAIN SURFACE DATA

dialog box:
Field Name Value
Export to File Bedrock Surface.csv

Field containing Z values [LITHOLOGY].[Depth]

Z Values are Depth, convert to elevation

Notice that we are exporting LITHOLOGY records, as opposed to POINT records (exported in the
previous export operation). We will need to filter the data to obtain records for bedrock
lithology layers only.

3. Click the Depth Table Filter tab. The Filter Field value must be in the same table as the Z
values. Enter the following values:

Field Name Value

Filter Field [LITHOLOGY].[Graphic]

Filter Operator =

Filter Comparison bedrock

Which Depth First

The criterion expressed here is “the Graphic field value in the LITHOLOGY table is equal to
‘bedrock’.” By setting Which Depth as “First’, the top depth of the bedrock layer is selected
rather than the bottom depth.

4. Click OK to generate the export file then click OK to dismiss the status log.

Importing the Surface Files into GEO5

In the GEO5 Terrain module, one surface must be specified as the ‘Terrain’ (ground surface), and
additional surfaces can then be specified. Do the following:

1. Open the GEO5 Terrain module.
2. Select the Basic Data tab in the vertical tab bar at right.

3
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Select File P> Import P Format GI1 (gINT interface points). The Data Import in gINT Format

dialog box appears.

Data import in gINT format

Daka impork

X

File af terrain points : |

Files of interface points ;

Marne of file of interfaces

[ K

[ Add

[¥ Insert

B |
B |
B Renoe |

[=| Remove

Cancel |

Click the Open button. This is to open the data file for the ground (terrain) surface.

Select ‘ground surface.gil’ and click Open. This sets the File of Terrain Points setting to

‘ground surface.gil’.

Click the Add button. Select the ‘bedrock surface.gil’ file and click Open. This adds the data
from this file to the list of subsurface layers.

Data import in gINT format

Daka impork

File of kerrain points : | ground surface.gil

Files of inkerface points :

E
x)

Mame af file of interfaces

bedrock surface.gil

gINT Software, Inc.

[H Irsert

Brert |
= Remove

Click OK. The points are added to the GEO5 display.
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Click the Generate tab in the right-hand tab bar, then the Generate button at lower left. The
two surfaces are plotted.

Geo 5 - Terrain [Untitled.gtr*]

File Edit Input Pictures Settings Help

D - BB @ ol L MEMHRERE &y Qaq EdoEHS BT s | o show
Construction stage : [ [t]

Modes =
25 Project
%Basic data

& Soils

B4 Assion

(ﬁ Poirts
om0 Edges
Qa \Water

Ef] Generate

] Poink-construc,

[ Line-canstruc,

= Launching

Generation parameters Visualization parameters A
Madel of terrain is
Smoaothing : none hd ™ Grid step ¢ 20,62 [m] generated,
Active edge : 0.0 [%] I Contour lines step ! 1,77 [m]
‘Yardage
r Pictures =
Add picture
Generate ]
% ™ Gererate | [=l Cancel model | Total : 0
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More Complex Surface Export Scenarios

Using the Standard Export Dialog Box

The online help topic, Help P Index » Exporting to a Contouring Program (how-to guide), describes a
number of ways to use the fields in the EXPORT GEO5 TERRAIN SURFACE DATA dialog box. This help
topic is actually written for the File » Import/Export P Export Contouring Data option, but the fields
have the same names and functionality. The following surface export scenarios (using the export dialog
box) are described in the help topic:

Surface Elevation

Water Depth

Water Elevation

Strata Top Elevations

Strata Bottom Elevations

Top Surface of Chemical Concentration Above a Particular Value

Bottom Surface of Chemical Concentration Above a Particular Value
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Using a Text Table Report Form

For completely customized surface output to a .gil file, you can design a Text Table report form and
use it to generate the data file directly in OUTPUT. This approach does not use the File p GEO5
Export options at all.

To see an example of how a custom .gil file can be exported using text table report output, do the
following:

A W N P

Ensure that the “geo5 terrain export.gpj’ project and ‘geo5 export.glb’ library are active.
Go to OUTPUT P> Text Tables.
Select the ‘CONTOUR STRATA TOP GEO5 TERRAIN’ report in the object selector.

Preview the report. In the Report Variables dialog box, enter ‘bedrock’ for Stratum Name
then click OK. The text table preview appears:

BTRATAL TOP ELEVATICIS

Im ¥ ¥ z
' ft ft ft
'========================================
B- 1 E62.7 1434.5 15
B- =z 660.6 145z.9 7
B- 3 T69.7 1437.58 1
E- 4 875.5 1454. 6 3
B- & 955 1454. 45 -15
E- =& 1019.58 1473.1 -z8
E_ 7 1120.5 1463 -35

- 8 1219.6 1474.7 -15
E— =] 1431 1469.7 el

- 10 1533.8 1476.4 -25
E— 11 1860.7 1444.5 2
E- 1z 556.6 1254.5 6

- 13 £79.1 1233 g
E_ 14 565.3 1065 2
g— 15 5Z26.3 878.7 -10

- 16 536.4 727.6 -3
g— 17 561.6 652 -7

- 15 5z28 E&& -1z
E- 19 53g.1 512.6 -12
B- z0 £25.4 480.7 -13
E- 21 711 435.4 -13
B- Z2 539.5 333 -8
B- 23 25,4 334.6 -8
B- Z4 559.9 254.1 -3
E- 25 £50.5 213.8 -3

Close the preview. Click the Browse === button to the right of Export to File. Select a Save as
Type of ‘GEO5 Terrain Surface (*.gil)’ and enter a file name of ‘bedrock text table’. Click
Save.

Click the Export button in the OUTPUT tab. As before, enter ‘bedrock’ in the Stratum Name
report variable, and click OK to close the report variables dialog box.
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7. Open the ‘bedrock text table.gil’ file with a text editor.

I bedrock text table.gil - Notepad

INTEGRATING GEO5 wWITH gINT

File  Edit

Format  View Help

F*HEADER
VERSION, CHARSET
1,0

HEROINTS

ID,X,¥,Z

,Ft, L, ft

B- 1,562.7,1434.5,1
B- 2,660.6,1452.9,7
B- 3,769.7,1437.8,1
B- 4,875.5,1454.6,3
B- 5,956,1454.6,-15
B- 6,1015.8,1473.1,-28
B- 7,1120.5,1463,-38
B- 8,1219.6,1474.7,-15
B- 9,1431,1469,.7,4

B- 10,1583.8,1476.4,-25
B- 11,1860.7,1444,5,2
B- 12,556.6,1254.8,6

B- 13,679.1,1233,8

B- 14, 568.3,1065,2

B- 15,526.3,878.7,-10
B- 16,536.4,727.6,-8

B- 17, 561.6,552, -7

B- 18,528,558, -12

B- 19, 538.1,512.6,-12
B- 20,625.4,480.7,-13
B- 21, 711,435.4,-13

B- 22,539.8,333,-8

B- 23,625.4,334.6,-8

B- 24,559.9,254.1, -3

B- 25,650.5,213.8, -3

B- 26, 546.5,158.3,7

B- 27,670.7,148.3,2

||<

Notice that this is a .gil file in correct format.

8. Close the text editor.
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9. Go to REPORT DESIGN P Text Tables. The report form we just used for the export appears as
shown:

2= REPORT DESIGN - Text Tables: c:\program files\gint\libraries\geo5\geo5 export.glb
File Edit Farmat Mavigation Help

=] = [ (1 [CONTOUR STRATA TOP GEDS TERRAIN ~ | D
INPUT | OUTPUT | DATA DESIGN REPORT DESIGN | SYMBOL DESIGN | DRAWINGS | UTILITIES

Logs | Fences | Graphs | Histograms | Graphic Tables Text Tables | Graphic Text Docs | Text Docs | Site Maps

[~ Separate Sets Table Field Paste System Items Paste
PROJECT | [Location | [Functions x| [#ASHTO Group_Ind > |
Page Header

tSTRFITH TOP ELEUATIODNS

Body Columns

Header Text Dutput Condition Data Expression Format Width Align Wrap
String
[1] <<POINT .PointlD>> 10
<> O
X <<EastAtDepth[<<5ql(Select Min[[LITHOLOGY].[Depth]) _ 10
ft From [LITHOLOGY] _ O
Where [LITHOLOGY].[PointID] = "<<PointiD>>"
b <<NorthAtDepth[<<Sql(Select Min[[LITHOLOGY].[Depth]) _ 10
ft From [LITHOLOGY] _ O
Where [LITHOLOGY].[PointID] = "¢<PointlD>>"
z <«<Calc[<<POINT Elevation>> - <<PlungeFactor>> * _ 10
ft <<5ql(5elect Min[[LITHOLOGY]. [Depth]) _ O
From [LITHOLOGY] _
* O
< | >
Row 1
of 4

|Page Footer
<<{PROJECT .Hame>>

10. Notice that the report layout is in three sections: Page Header, Body Columns, and Page
Footer. The Page Header and Page Footer sections only apply when you preview or print.
They are ignored when you export.

In the Body Columns section you are defining output, as a table of comma-separated text
values, of the points in the project. The desired output will look like this:

1D,X,Y,Z

,Ft,ft,ft

B- 1,562.7,1434.5,18
B- 2,660.6,1452.9,7
B- 3,769.7,1437.8,1
B- 4,875.5,1454.6,3
(etc.)

o The “header” of the “table” consists of two rows, one containing the field names required
by GEOS5 (ID,X,Y,Z), the other containing the units (null,ft,ft,ft in this case).

o The “body” of the “table” consists of rows of data, each with the values for each of the
four fields for a given point.
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%~ Note: The “**HEADER’ section and “**POINTS’ title are added automatically when you
choose .gil as an export format, and so are not included in the report design.

To accomplish this you create four rows in the Body Columns section of the report layout, one
for each of the four fields.

o In the Header Text column, you enter the two lines of text that is to appear in the two
“table header” rows for the field.

= For the ID field, this is ‘ID’, followed by Enter, followed by *<<g>>’. The ‘<<g>>’
character is a non-breaking space, and creates the null output we want on the units
line.

= For the X, Y and Z fields this is the field name, followed by Enter, followed by the
units.

o In the Data Expression column, you enter a SQL expression that calculates the value of the
given output field for each data point to be exported.

. To see the full contents of a Data Expression SQL statement, double-click the one in the
second row, for X. This is the SQL statement:

<<EastAtDepth(<<Sgl (Select Min([LITHOLOGY].[Depth]) _
From [LITHOLOGY] _

Where [LITHOLOGY].[PointiD]

[LITHOLOGY]. [Graphic]

"<<PointID>>" And _
"<<Report Var.Stratum_Name>>"__

)>>,
<<POINT.Bearing>>_
)>>

This expression uses the EastAtDepth() function to generate the east coordinate from the
Depth and Bearing fields. Refer to Help P> Index P EastAtDepth (function) for information on
this function. It also uses the Sqgl() function to extract the minimum depth of a specified
lithology layer in a specified point (refer to Help P Index P> Sql (function)). The '<<Report
Var.Stratum_Name>>' expression gets the value you enter for Stratum Name in the Report
Variables dialog box.

. Press Esc to exit the expression entry box.

For information on how to configure data expressions for several surface export scenarios,
refer to Help P> Index » Exporting to a Contouring Program (how-to guide).
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